{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2021-3611 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2021-3611 is a medium-severity denial of service vulnerability in Qemu Qemu, published on 11 May 2022. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-3611 and fix it if it is affected.\n\nWhat it is: CVE-2021-3611 is a medium-severity denial of service vulnerability in Qemu Qemu, published on 11 May 2022. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-3611 in the wild and no public exploit code.\n\nAffected product: Qemu Qemu. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-3611/ (Markdown: https://insights.sbomify.com/CVE-2021-3611/index.md)","id":"CVE-2021-3611","markdown":"https://insights.sbomify.com/CVE-2021-3611/index.md","name":"CVE-2021-3611","record":{"aliases":["AZL-35150","DEBIAN-CVE-2021-3611","GHSA-rj8x-cp5p-j26r","SUSE-SU-2025:0432-1","UBUNTU-CVE-2021-3611"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"QEMU emulator","requires_auth":"low_privilege","summary":"A malicious guest can crash the QEMU host process via a stack overflow in the Intel HD Audio device, causing denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"qemu","vendor":"qemu"},{"product":"enterprise_linux","vendor":"redhat"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"},{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"A stack overflow vulnerability was found in the Intel HD Audio device (intel-hda) of QEMU. A malicious guest could use this flaw to crash the QEMU process on the host, resulting in a denial of service condition. The highest threat from this vulnerability is to system availability. This flaw affects QEMU versions prior to 7.0.0.","ecosystems":["SUSE:Linux Enterprise Micro 5.3","SUSE:Linux Enterprise Micro 5.4"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in QEMU","id":"CVE-2021-3611","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"qemu:qemu","products":["qemu:qemu","redhat:enterprise_linux"],"type":"denial_of_service","year":"2021"},"n_packages":2,"n_references":4,"next":{"headline":"Memory corruption in kernel","id":"CVE-2021-3612"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Micro 5.3","fixed":["6.2.0-150400.37.40.1"],"introduced":["0"],"last_affected":[],"package":"qemu","purl":"pkg:rpm/suse/qemu\u0026distro=SUSE%20Linux%20Enterprise%20Micro%205.3","source":"SUSE-SU-2025:0432-1"},{"ecosystem":"SUSE:Linux Enterprise Micro 5.4","fixed":["6.2.0-150400.37.40.1"],"introduced":["0"],"last_affected":[],"package":"qemu","purl":"pkg:rpm/suse/qemu\u0026distro=SUSE%20Linux%20Enterprise%20Micro%205.4","source":"SUSE-SU-2025:0432-1"}],"prev":{"headline":"Memory corruption in ImageMagick","id":"CVE-2021-3610"},"products":["QEMU"],"published":"2022-05-11","related":[{"cvss_score":10,"headline":"Null dereference in n/a","id":"CVE-2022-36648","kev_date_added":null,"published":"2023-08-22"},{"cvss_score":10,"headline":"Race condition in n/a","id":"CVE-2015-8556","kev_date_added":null,"published":"2017-03-24"},{"cvss_score":9.9,"headline":"Use after free in n/a","id":"CVE-2009-3616","kev_date_added":null,"published":"2009-10-23"},{"cvss_score":9.8,"headline":"Command injection in n/a","id":"CVE-2019-12928","kev_date_added":null,"published":"2019-06-24"},{"cvss_score":9.8,"headline":"Command injection in n/a","id":"CVE-2019-12929","kev_date_added":null,"published":"2019-06-24"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2018-20815","kev_date_added":null,"published":"2019-05-31"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2017-8380","kev_date_added":null,"published":"2017-08-28"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"A malicious guest can crash the QEMU host process via a stack overflow in the Intel HD Audio device, causing denial of service.","url":"https://insights.sbomify.com/CVE-2021-3611/"}