{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.gobblin:gobblin-core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-36152 in the wild and no public exploit code.","fix":"Upgrade org.apache.gobblin:gobblin-core to 0.16.0 or later.","what":"CVE-2021-36152 is a critical vulnerability in Apache Gobblin, published on 4 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-36152 and fix it if it is affected.\n\nWhat it is: CVE-2021-36152 is a critical vulnerability in Apache Gobblin, published on 4 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-36152 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.gobblin:gobblin-core (Maven): affected all versions; fixed in 0.16.0\n- org.apache.gobblin:gobblin-core (Maven): affected all versions; fixed in 0.16.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-36152/ (Markdown: https://insights.sbomify.com/CVE-2021-36152/index.md)","id":"CVE-2021-36152","markdown":"https://insights.sbomify.com/CVE-2021-36152/index.md","name":"CVE-2021-36152","record":{"aliases":["GHSA-q5rx-8c2h-5q7j"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Gobblin","requires_auth":"none","summary":"Apache Gobblin trusts all LDAP certificates, allowing attackers to bypass TLS validation and potentially intercept or manipulate LDAP traffic.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"gobblin","vendor":"apache"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[],"description":"Apache Gobblin trusts all certificates used for LDAP connections in Gobblin-as-a-Service. This affects versions \u003c= 0.15.0. Users should update to version 0.16.0 which addresses this issue.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Insecure TrustManager used in LDAP connections","id":"CVE-2021-36152","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"security_feature_bypass","year":"2021"},"n_packages":2,"n_references":1,"next":{"headline":"Incomplete Internal State Distinction in GRPCWebToHTTP2ServerCodec","id":"CVE-2021-36153"},"packages":[{"ecosystem":"Maven","fixed":["0.16.0"],"introduced":["0"],"last_affected":[],"package":"org.apache.gobblin:gobblin-core","purl":null,"source":"GHSA-q5rx-8c2h-5q7j"},{"ecosystem":"Maven","fixed":["0.16.0"],"introduced":["0"],"last_affected":[],"package":"org.apache.gobblin:gobblin-core","purl":"pkg:maven/org.apache.gobblin/gobblin-core","source":"GHSA-q5rx-8c2h-5q7j"}],"prev":{"headline":"Local Credentials Disclosure Vulnerability","id":"CVE-2021-36151"},"products":["Apache Gobblin"],"published":"2022-02-04","related":[{"cvss_score":5.5,"headline":"Local Credentials Disclosure Vulnerability","id":"CVE-2021-36151","kev_date_added":null,"published":"2022-02-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Apache Software Foundation"]},"summary":"Apache Gobblin trusts all LDAP certificates, allowing attackers to bypass TLS validation and potentially intercept or manipulate LDAP traffic.","url":"https://insights.sbomify.com/CVE-2021-36152/"}