# CVE-2021-36152: Insecure TrustManager used in LDAP connections

> Apache Gobblin trusts all LDAP certificates, allowing attackers to bypass TLS validation and potentially intercept or manipulate LDAP traffic.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Feb 2022
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-q5rx-8c2h-5q7j

## What is CVE-2021-36152?

CVE-2021-36152 is a critical vulnerability in Apache Gobblin, published on 4 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Gobblin trusts all certificates used for LDAP connections in Gobblin-as-a-Service. This affects versions <= 0.15.0. Users should update to version 0.16.0 which addresses this issue.

## Which versions are affected by CVE-2021-36152?

2 open source packages ship an affected version, including org.apache.gobblin:gobblin-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.gobblin:gobblin-core` | Maven | All versions | 0.16.0 |
| `org.apache.gobblin:gobblin-core` | Maven | All versions | 0.16.0 |

Products: Apache Gobblin.

## How do I fix CVE-2021-36152?

Upgrade org.apache.gobblin:gobblin-core to 0.16.0 or later.

## Is CVE-2021-36152 being exploited?

There is no known exploitation of CVE-2021-36152 in the wild and no public exploit code.

## Other vulnerabilities in Apache Gobblin

- [CVE-2021-36151](https://insights.sbomify.com/CVE-2021-36151/): Local Credentials Disclosure Vulnerability (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-36152 and fix it if it is affected.

What it is: CVE-2021-36152 is a critical vulnerability in Apache Gobblin, published on 4 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-36152 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.gobblin:gobblin-core (Maven): affected all versions; fixed in 0.16.0
- org.apache.gobblin:gobblin-core (Maven): affected all versions; fixed in 0.16.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-36152/ (Markdown: https://insights.sbomify.com/CVE-2021-36152/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-36152
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-36152
- OSV: https://osv.dev/vulnerability/CVE-2021-36152

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-36152/
Summaries are generated and may contain mistakes; the official description above is the record.
