# CVE-2021-36155: Uncontrolled Resource Consumption in LengthPrefixedMessageReader

> Remote attackers can cause denial of service in gRPC Swift by triggering uncontrolled resource consumption via arbitrary buffer allocations.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jul 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-rxmj-hg9v-vp3p

## What is CVE-2021-36155?

CVE-2021-36155 is a high-severity denial of service vulnerability in n/a, published on 9 Jul 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

LengthPrefixedMessageReader in gRPC Swift 1.1.0 and earlier allocates buffers of arbitrary length, which allows remote attackers to cause uncontrolled resource consumption and deny service.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2021-36155?

2 open source packages ship an affected version, including github.com/grpc/grpc-swift. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/grpc/grpc-swift` | SwiftURL | All versions | 1.2.0 |
| `github.com/grpc/grpc-swift` | SwiftURL | All versions | 1.2.0 |

Products: Linuxfoundation Grpc Swift.

## How do I fix CVE-2021-36155?

Upgrade github.com/grpc/grpc-swift to 1.2.0 or later.

## Is CVE-2021-36155 being exploited?

There is no known exploitation of CVE-2021-36155 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-24777](https://insights.sbomify.com/CVE-2022-24777/): Denial of Service via reachable assertion in grpc-swift (high 7.5)
- [CVE-2021-36153](https://insights.sbomify.com/CVE-2021-36153/): Incomplete Internal State Distinction in GRPCWebToHTTP2ServerCodec (high 7.5)
- [CVE-2021-36154](https://insights.sbomify.com/CVE-2021-36154/): Uncontrolled Recursion in HTTP2ToRawGRPCServerCodec (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-36155 and fix it if it is affected.

What it is: CVE-2021-36155 is a high-severity denial of service vulnerability in n/a, published on 9 Jul 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-36155 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/grpc/grpc-swift (SwiftURL): affected all versions; fixed in 1.2.0
- github.com/grpc/grpc-swift (SwiftURL): affected all versions; fixed in 1.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-36155/ (Markdown: https://insights.sbomify.com/CVE-2021-36155/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-36155
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-36155
- OSV: https://osv.dev/vulnerability/CVE-2021-36155

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-36155/
Summaries are generated and may contain mistakes; the official description above is the record.
