CVE-2021-3619 Rapid7 Velociraptor Notebooks Authenticated Persistent XSS

Low 3.5 Published Updated

Authenticated users can inject persistent XSS via malicious uploads, potentially executing code or taking over accounts in Velociraptor.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2021-3619?

CVE-2021-3619 is a low-severity cross-site scripting vulnerability in Rapid7 Velociraptor, published on 17 Aug 2021. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

Rapid7 Velociraptor 0.5.9 and prior is vulnerable to a post-authentication persistent cross-site scripting (XSS) issue, where an authenticated user could abuse MIME filetype sniffing to embed executable code on a malicious upload. This issue was fixed in version 0.6.0. Note that login rights to Velociraptor is nearly always reserved for trusted and verified users with IT security backgrounds.

Weakness: CWE-79

Which versions are affected by CVE-2021-3619?

It affects 1 product.

Products include Rapid7 Velociraptor.

How do I fix CVE-2021-3619?

No fix has been published for CVE-2021-3619 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2021-3619 being exploited?

There is no known exploitation of CVE-2021-3619 in the wild and no public exploit code.

Sources

Also known as GHSA-m6q8-qh76-5hfr.

Is CVE-2021-3619 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free