# CVE-2021-36213: HashiCorp Consul L7 deny intention results in an allow action

> HashiCorp Consul fails open on specific L7 deny policies, allowing unauthorized L4 traffic bypassing intended security controls.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jul 2021
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-consul-2021-36213, GHSA-8h2g-r292-j8xh, GO-2022-0895, UBUNTU-CVE-2021-36213

## What is CVE-2021-36213?

CVE-2021-36213 is a high-severity vulnerability in n/a, published on 17 Jul 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

HashiCorp Consul and Consul Enterprise 1.9.0 through 1.10.0 default deny policy with a single L7 application-aware intention deny action cancels out, causing the intention to incorrectly fail open, allowing L4 traffic. Fixed in 1.9.8 and 1.10.1.

## Which versions are affected by CVE-2021-36213?

4 open source packages ship an affected version, including github.com/hashicorp/consul and consul. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hashicorp/consul` | Go | All versions | 1.10.1 |
| `github.com/hashicorp/consul` | Go | All versions | 1.10.1 |
| `github.com/hashicorp/consul` | Go | All versions | 1.10.1 |
| `consul` | Bitnami | From 1.9.0 | 1.9.8, 1.10.1 |

Products: Hashicorp Consul.

## How do I fix CVE-2021-36213?

Upgrade github.com/hashicorp/consul to 1.10.1 or later.

## Is CVE-2021-36213 being exploited?

There is no known exploitation of CVE-2021-36213 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-41805](https://insights.sbomify.com/CVE-2021-41805/): Privilege escalation in n/a (high 8.8)
- [CVE-2021-37219](https://insights.sbomify.com/CVE-2021-37219/): HashiCorp Consul Privilege Escalation Vulnerability (high 8.8)
- [CVE-2023-2816](https://insights.sbomify.com/CVE-2023-2816/): Consul Envoy Extension Downsteam Proxy Configuration By Upstream Service Owner (high 8.7)
- [CVE-2024-10006](https://insights.sbomify.com/CVE-2024-10006/): Consul L7 Intentions Vulnerable To Headers Bypass (high 8.3)
- [CVE-2024-10005](https://insights.sbomify.com/CVE-2024-10005/): Consul L7 Intentions Vulnerable To URL Path Bypass (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-36213 and fix it if it is affected.

What it is: CVE-2021-36213 is a high-severity vulnerability in n/a, published on 17 Jul 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-36213 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hashicorp/consul (Go): affected all versions; fixed in 1.10.1
- github.com/hashicorp/consul (Go): affected all versions; fixed in 1.10.1
- github.com/hashicorp/consul (Go): affected all versions; fixed in 1.10.1
- consul (Bitnami): affected from 1.9.0; fixed in 1.9.8, 1.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-36213/ (Markdown: https://insights.sbomify.com/CVE-2021-36213/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-36213
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-36213
- OSV: https://osv.dev/vulnerability/CVE-2021-36213

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-36213/
Summaries are generated and may contain mistakes; the official description above is the record.
