# CVE-2021-36218: An issue was discovered in SKALE sgxwallet 1.58.3.


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 27 Sep 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-h23p-6vvh-q288

## What is CVE-2021-36218?

CVE-2021-36218 is a high-severity vulnerability in n/a, published on 27 Sep 2021. 

### Official description

An issue was discovered in SKALE sgxwallet 1.58.3. sgx_disp_ippsAES_GCMEncrypt allows an out-of-bounds write, resulting in a segfault and compromised enclave. This issue describes a buffer overflow, which was resolved prior to v1.77.0 and not reproducible in latest sgxwallet v1.77.0

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2021-36218?

It affects 1 product.


Products: Skale Sgxwallet.

## How do I fix CVE-2021-36218?

No fix has been published for CVE-2021-36218 yet. Limit exposure of the affected software until one is available.

## Is CVE-2021-36218 being exploited?

There is no known exploitation of CVE-2021-36218 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-36219](https://insights.sbomify.com/CVE-2021-36219/): Use after free in n/a (critical 9.8)
- [CVE-2023-36198](https://insights.sbomify.com/CVE-2023-36198/): Memory corruption in n/a (high 7.5)
- [CVE-2023-36199](https://insights.sbomify.com/CVE-2023-36199/): Null dereference in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-36218 and fix it if it is affected.

What it is: CVE-2021-36218 is a high-severity vulnerability in n/a, published on 27 Sep 2021. 
Exploitation: There is no known exploitation of CVE-2021-36218 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-36218/ (Markdown: https://insights.sbomify.com/CVE-2021-36218/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-36218
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-36218
- OSV: https://osv.dev/vulnerability/CVE-2021-36218

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-36218/
Summaries are generated and may contain mistakes; the official description above is the record.
