# CVE-2021-36221: Race condition in n/a

> A race condition in the Go ReverseProxy can cause a panic, leading to denial of service for applications using this component.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Aug 2021
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-golang-2021-36221, DEBIAN-CVE-2021-36221, GHSA-6qcx-qr4g-4fx9, GO-2021-0245, MGASA-2021-0416, RHSA-2021:4765, SUSE-SU-2021:2787-1, SUSE-SU-2021:2788-1, UBUNTU-CVE-2021-36221, openSUSE-SU-2021:1199-1, openSUSE-SU-2021:1207-1, openSUSE-SU-2021:2787-1, openSUSE-SU-2021:2788-1

## What is CVE-2021-36221?

CVE-2021-36221 is a medium-severity vulnerability in Debian Debian Linux, published on 8 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Go before 1.15.15 and 1.16.x before 1.16.7 has a race condition that can lead to a net/http/httputil ReverseProxy panic upon an ErrAbortHandler abort.

Weakness: CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization)

## Which versions are affected by CVE-2021-36221?

2 open source packages ship an affected version, including golang and stdlib. It affects 5 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `golang` | Bitnami | All versions | 1.15.15, 1.16.7 |
| `stdlib` | Go | All versions | 1.15.15, 1.16.7 |
| `openshift-serverless-clients` | Red Hat:serverless:1.0::el8 | All versions | 0:0.25.1-1.el8 |
| `go1.15` | SUSE:Enterprise Storage 6 | All versions | 1.15.15-1.39.1 |
| `go1.15` | SUSE:Linux Enterprise High Performance Computing 15 SP1-ESPOS | All versions | 1.15.15-1.39.1 |
| `go1.15` | SUSE:Linux Enterprise High Performance Computing 15 SP1-LTSS | All versions | 1.15.15-1.39.1 |
| `go1.15` | SUSE:Linux Enterprise Module for Development Tools 15 SP2 | All versions | 1.15.15-1.39.1 |
| `go1.16` | SUSE:Linux Enterprise Module for Development Tools 15 SP2 | All versions | 1.16.7-1.23.1 |
| `go1.15` | SUSE:Linux Enterprise Module for Development Tools 15 SP3 | All versions | 1.15.15-1.39.1 |
| `go1.16` | SUSE:Linux Enterprise Module for Development Tools 15 SP3 | All versions | 1.16.7-1.23.1 |
| `go1.15` | SUSE:Linux Enterprise Server 15 SP1-BCL | All versions | 1.15.15-1.39.1 |
| `go1.15` | SUSE:Linux Enterprise Server 15 SP1-LTSS | All versions | 1.15.15-1.39.1 |
| `go1.15` | SUSE:Linux Enterprise Server for SAP Applications 15 SP1 | All versions | 1.15.15-1.39.1 |
| `go1.15` | SUSE:Manager Proxy 4.0 | All versions | 1.15.15-1.39.1 |
| `go1.15` | SUSE:Manager Retail Branch Server 4.0 | All versions | 1.15.15-1.39.1 |
| `go1.15` | SUSE:Manager Server 4.0 | All versions | 1.15.15-1.39.1 |
| `go1.15` | openSUSE:Leap 15.2 | All versions | 1.15.15-lp152.26.1 |
| `go1.16` | openSUSE:Leap 15.2 | All versions | 1.16.7-lp152.8.1 |
| `go1.15` | openSUSE:Leap 15.3 | All versions | 1.15.15-1.39.1 |
| `go1.16` | openSUSE:Leap 15.3 | All versions | 1.16.7-1.23.1 |

Products: Debian Debian Linux, Fedoraproject Fedora, Golang Go, Oracle Timesten In-Memory Database, Siemens Scalance Lpe9403 Firmware.

## How do I fix CVE-2021-36221?

Upgrade golang to a fixed version for your release line: 1.15.15 or 1.16.7.

## Is CVE-2021-36221 being exploited?

There is no known exploitation of CVE-2021-36221 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-36221 and fix it if it is affected.

What it is: CVE-2021-36221 is a medium-severity vulnerability in Debian Debian Linux, published on 8 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-36221 in the wild and no public exploit code.

Affected packages and fixed versions:
- golang (Bitnami): affected all versions; fixed in 1.15.15, 1.16.7
- stdlib (Go): affected all versions; fixed in 1.15.15, 1.16.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-36221/ (Markdown: https://insights.sbomify.com/CVE-2021-36221/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-36221
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-36221
- OSV: https://osv.dev/vulnerability/CVE-2021-36221

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-36221/
Summaries are generated and may contain mistakes; the official description above is the record.
