# CVE-2021-36359: Code injection in n/a

> Authenticated attackers can execute arbitrary code via XML tag injection in the exportpdf feature of OrbiTeam BSCW Classic.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 30 Aug 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-764h-r5xf-7cf5

## What is CVE-2021-36359?

CVE-2021-36359 is a high-severity code injection vulnerability in n/a, published on 30 Aug 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OrbiTeam BSCW Classic before 7.4.3 allows exportpdf authenticated remote code execution (RCE) via XML tag injection because reportlab\platypus\paraparser.py (reached via bscw.cgi op=_editfolder.EditFolder) calls eval on attacker-supplied Python code. This is fixed in 5.0.12, 5.1.10, 5.2.4, 7.3.3, and 7.4.3.

Weakness: CWE-91 (XML Injection)

## Which versions are affected by CVE-2021-36359?

It affects 1 product.


Products: Bscw Bscw Classic.

## How do I fix CVE-2021-36359?

No fix has been published for CVE-2021-36359 yet. Limit exposure of the affected software until one is available.

## Is CVE-2021-36359 being exploited?

There is no known exploitation of CVE-2021-36359 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-39271](https://insights.sbomify.com/CVE-2021-39271/): Code injection in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-36359 and fix it if it is affected.

What it is: CVE-2021-36359 is a high-severity code injection vulnerability in n/a, published on 30 Aug 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-36359 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-36359/ (Markdown: https://insights.sbomify.com/CVE-2021-36359/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-36359
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-36359
- OSV: https://osv.dev/vulnerability/CVE-2021-36359

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-36359/
Summaries are generated and may contain mistakes; the official description above is the record.
