# CVE-2021-36373: Apache Ant TAR archive denial of service vulnerability

> Attackers can cause denial of service in Apache Ant builds by providing specially crafted TAR archives that trigger excessive memory allocation.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Jul 2021
- **Updated:** 4 Aug 2024
- **Also known as:** AZL-25953, AZL-34808, CLEANSTART-2025-YD79563, DEBIAN-CVE-2021-36373, GHSA-q5r4-cfpx-h6fh, MINI-3pg8-r5jw-c42f, MINI-c4rw-r67c-fg2c, MINI-w9jv-c4rq-wc5r, UBUNTU-CVE-2021-36373

## What is CVE-2021-36373?

CVE-2021-36373 is a medium-severity denial of service vulnerability in Oracle Agile Product Lifecycle Management, published on 14 Jul 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

When reading a specially crafted TAR archive an Apache Ant build can be made to allocate large amounts of memory that finally leads to an out of memory error, even for small inputs. This can be used to disrupt builds using Apache Ant. Apache Ant prior to 1.9.16 and 1.10.11 were affected.

Weakness: CWE-130 (Improper Handling of Length Parameter Inconsistency)

## Which versions are affected by CVE-2021-36373?

4 open source packages ship an affected version, including org.apache.ant:ant. It affects 32 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.ant:ant` | Maven | All versions | 1.9.16 |
| `org.apache.ant:ant` | Maven | All versions | 1.9.16 |
| `org.apache.ant:ant` | Maven | From 1.10.0 | 1.10.11 |
| `org.apache.ant:ant` | Maven | From 1.10.0 | 1.10.11 |

Products: Apache Ant, Oracle Agile Product Lifecycle Management, Oracle Banking Trade Finance, Oracle Banking Treasury Management, Oracle Communications Cloud Native Core Automated Test Suite, Oracle Communications Cloud Native Core Binding Support Function, Oracle Communications Order and Service Management, Oracle Communications Unified Inventory Management, Oracle Enterprise Repository, Oracle Financial Services Analytical Applications Infrastructure, Oracle Insurance Policy Administration, Oracle Primavera Gateway, Oracle Primavera Unifier, Oracle Real-Time Decision Server, Oracle Retail Advanced Inventory Planning, Oracle Retail Back Office, Oracle Retail Bulk Data Integration, Oracle Retail Central Office, Oracle Retail Eftlink, Oracle Retail Extract Transform and Load and 12 more.

## How do I fix CVE-2021-36373?

Upgrade org.apache.ant:ant to a fixed version for your release line: 1.9.16 or 1.10.11.

## Is CVE-2021-36373 being exploited?

There is no known exploitation of CVE-2021-36373 in the wild and no public exploit code.

## Other vulnerabilities in Oracle Agile Product Lifecycle Management

- [CVE-2020-11979](https://insights.sbomify.com/CVE-2020-11979/): Code injection in Apache Ant (high 7.5)
- [CVE-2026-78254](https://insights.sbomify.com/CVE-2026-78254/): Apache Ant: Path traversal in ftp and scp tasks allows arbitrary file write (high 7.4)
- [CVE-2020-1945](https://insights.sbomify.com/CVE-2020-1945/): Sensitive Data Exposure in Apache Ant (medium 6.3)
- [CVE-2021-36374](https://insights.sbomify.com/CVE-2021-36374/): Apache Ant ZIP, and ZIP based, archive denial of service vulerability (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-36373 and fix it if it is affected.

What it is: CVE-2021-36373 is a medium-severity denial of service vulnerability in Oracle Agile Product Lifecycle Management, published on 14 Jul 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-36373 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.ant:ant (Maven): affected all versions; fixed in 1.9.16
- org.apache.ant:ant (Maven): affected all versions; fixed in 1.9.16
- org.apache.ant:ant (Maven): affected from 1.10.0; fixed in 1.10.11
- org.apache.ant:ant (Maven): affected from 1.10.0; fixed in 1.10.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-36373/ (Markdown: https://insights.sbomify.com/CVE-2021-36373/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-36373
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-36373
- OSV: https://osv.dev/vulnerability/CVE-2021-36373

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-36373/
Summaries are generated and may contain mistakes; the official description above is the record.
