CVE-2021-36397 Moodle has Incorrect Default Permissions
Attackers can delete messages belonging to other users due to insufficient capability checks in Moodle.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-36397?
CVE-2021-36397 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 6 Mar 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In Moodle, insufficient capability checks meant message deletions were not limited to the current user.
Weakness: CWE-276
Which versions are affected by CVE-2021-36397?
7 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 3.9.8 |
moodle/moodle Packagist | All versions | 3.9.8 |
moodle/moodle Packagist | From 3.10.0-beta | 3.10.5 |
moodle/moodle Packagist | From 3.10.0-beta | 3.10.5 |
moodle/moodle Packagist | From 3.11.0-beta | 3.11.1 |
moodle/moodle Packagist | From 3.11.0-beta | 3.11.1 |
1 more packages
moodle Bitnami | All versions | 3.9.8, 3.10.5, 3.11.1 |
Products include Moodle Moodle.
How do I fix CVE-2021-36397?
Upgrade moodle/moodle to a fixed version for your release line: 3.9.8, 3.10.5 or 3.11.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2021-36397 being exploited?
There is no known exploitation of CVE-2021-36397 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2021-36397, GHSA-2wmj-8mqg-r9q8, UBUNTU-CVE-2021-36397.