CVE-2021-36399 Moodle Cross-site Scripting vulnerability
Attackers can inject malicious scripts via quiz override ID numbers, potentially stealing user sessions or executing code in Moodle.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-36399?
CVE-2021-36399 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 6 Mar 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
In Moodle, ID numbers displayed in the quiz override screens required additional sanitizing to prevent a stored XSS risk.
Weakness: CWE-79
Which versions are affected by CVE-2021-36399?
7 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 3.9.8 |
moodle/moodle Packagist | All versions | 3.9.8 |
moodle/moodle Packagist | From 3.10.0-beta | 3.10.5 |
moodle/moodle Packagist | From 3.10.0-beta | 3.10.5 |
moodle/moodle Packagist | From 3.11.0-beta | 3.11.1 |
moodle/moodle Packagist | From 3.11.0-beta | 3.11.1 |
1 more packages
moodle Bitnami | From 3.11.0 | 3.11.1 |
Products include Moodle Moodle.
How do I fix CVE-2021-36399?
Upgrade moodle/moodle to a fixed version for your release line: 3.9.8, 3.10.5 or 3.11.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2021-36399 being exploited?
There is no known exploitation of CVE-2021-36399 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2021-36399, GHSA-79jp-m64f-pgrc, UBUNTU-CVE-2021-36399.