CVE-2021-36401 Moodle vulnerable to Stored Cross-site Scripting
Attackers can inject malicious scripts via unsanitized ID numbers in HTML exports, potentially leading to session hijacking or code execution.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-36401?
CVE-2021-36401 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 6 Mar 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
In Moodle, ID numbers exported in HTML data formats required additional sanitizing to prevent a local stored XSS risk.
Weakness: CWE-79
Which versions are affected by CVE-2021-36401?
7 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 3.9.8 |
moodle/moodle Packagist | All versions | 3.9.8 |
moodle/moodle Packagist | From 3.10.0-beta | 3.10.5 |
moodle/moodle Packagist | From 3.10.0-beta | 3.10.5 |
moodle/moodle Packagist | From 3.11.0-beta | 3.11.1 |
moodle/moodle Packagist | From 3.11.0-beta | 3.11.1 |
1 more packages
moodle Bitnami | All versions | 3.9.8, 3.10.5, 3.11.1 |
Products include Moodle Moodle.
How do I fix CVE-2021-36401?
Upgrade moodle/moodle to a fixed version for your release line: 3.9.8, 3.10.5 or 3.11.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2021-36401 being exploited?
There is no known exploitation of CVE-2021-36401 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2021-36401, GHSA-g6h6-4fp6-w33w, UBUNTU-CVE-2021-36401.