# CVE-2021-3642: Observable Discrepancy in Wildfly Elytron

> Attackers can exploit timing differences in ScramServer to potentially disclose sensitive information if the feature is enabled.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Aug 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-5499-qjvh-6j7w

## What is CVE-2021-3642?

CVE-2021-3642 is a medium-severity vulnerability in Redhat Jboss Enterprise Application Platform, published on 5 Aug 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A flaw was found in Wildfly Elytron in versions prior to 1.10.14.Final, prior to 1.15.5.Final and prior to 1.16.1.Final where ScramServer may be susceptible to Timing Attack if enabled. The highest threat of this vulnerability is confidentiality.

Weakness: CWE-203 (Observable Discrepancy)

## Which versions are affected by CVE-2021-3642?

6 open source packages ship an affected version, including org.wildfly.security:wildfly-elytron. It affects 13 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.wildfly.security:wildfly-elytron` | Maven | All versions | 1.10.14 |
| `org.wildfly.security:wildfly-elytron` | Maven | All versions | 1.10.14 |
| `org.wildfly.security:wildfly-elytron` | Maven | From 1.11.0 | 1.15.5 |
| `org.wildfly.security:wildfly-elytron` | Maven | From 1.11.0 | 1.15.5 |
| `org.wildfly.security:wildfly-elytron` | Maven | From 1.16.0 | 1.16.1 |
| `org.wildfly.security:wildfly-elytron` | Maven | From 1.16.0 | 1.16.1 |

Products: Quarkus Quarkus, Redhat Build of Quarkus, Redhat Codeready Studio, Redhat Data Grid, Redhat Descision Manager, Redhat Integration Camel K, Redhat Integration Camel Quarkus, Redhat Jboss Enterprise Application Platform, Redhat Jboss Enterprise Application Platform Expansion Pack, Redhat Jboss Fuse, Redhat Openshift Application Runtimes, Redhat Process Automation, Redhat Wildfly Elytron.

## How do I fix CVE-2021-3642?

Upgrade org.wildfly.security:wildfly-elytron to a fixed version for your release line: 1.10.14, 1.15.5 or 1.16.1.

## Is CVE-2021-3642 being exploited?

There is no known exploitation of CVE-2021-3642 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Jboss Enterprise Application Platform

- [CVE-2022-4116](https://insights.sbomify.com/CVE-2022-4116/): Code injection in quarkus dev ui config editor (critical 9.8)
- [CVE-2022-2466](https://insights.sbomify.com/CVE-2022-2466/): Quarkus does not terminate HTTP requests header context (critical 9.8)
- [CVE-2024-12225](https://insights.sbomify.com/CVE-2024-12225/): Io.quarkus:quarkus-security-webauthn: quarkus webauthn unexpected authentication bypass (critical 9.1)
- [CVE-2026-39852](https://insights.sbomify.com/CVE-2026-39852/): Quarkus authorization bypass via semicolon path normalization inconsistency (high 8.8)
- [CVE-2022-0981](https://insights.sbomify.com/CVE-2022-0981/): Privilege escalation in quarkus (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-3642 and fix it if it is affected.

What it is: CVE-2021-3642 is a medium-severity vulnerability in Redhat Jboss Enterprise Application Platform, published on 5 Aug 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-3642 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.wildfly.security:wildfly-elytron (Maven): affected all versions; fixed in 1.10.14
- org.wildfly.security:wildfly-elytron (Maven): affected all versions; fixed in 1.10.14
- org.wildfly.security:wildfly-elytron (Maven): affected from 1.11.0; fixed in 1.15.5
- org.wildfly.security:wildfly-elytron (Maven): affected from 1.11.0; fixed in 1.15.5
- org.wildfly.security:wildfly-elytron (Maven): affected from 1.16.0; fixed in 1.16.1
- org.wildfly.security:wildfly-elytron (Maven): affected from 1.16.0; fixed in 1.16.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-3642/ (Markdown: https://insights.sbomify.com/CVE-2021-3642/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-3642
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-3642
- OSV: https://osv.dev/vulnerability/CVE-2021-3642

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-3642/
Summaries are generated and may contain mistakes; the official description above is the record.
