CVE-2021-36568 Moodle Cross-site Scripting vulnerability

Medium 5.4 Published Updated

Stored XSS in Moodle database activity fields allows attackers to inject scripts, potentially leading to session hijacking or code execution.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2021-36568?

CVE-2021-36568 is a medium-severity cross-site scripting vulnerability in Fedoraproject Fedora, published on 13 Sep 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

In certain Moodle products after creating a course, it is possible to add in a arbitrary "Topic" a resource, in this case a "Database" with the type "Text" where its values "Field name" and "Field description" are vulnerable to Cross Site Scripting Stored(XSS). This affects Moodle 3.11 and Moodle 3.10.4 and Moodle 3.9.7.

Weakness: CWE-79

Which versions are affected by CVE-2021-36568?

7 open source packages ship an affected version, including moodle/moodle and moodle. It affects 2 products.

PackageAffectedFixed in
moodle/moodle PackagistAll versions to 3.9.7None
moodle/moodle PackagistAll versions to 3.9.7None
moodle/moodle PackagistFrom 3.10.0 to 3.10.4None
moodle/moodle PackagistFrom 3.10.0 to 3.10.4None
moodle/moodle PackagistFrom 3.11.03.11.10
moodle/moodle PackagistFrom 3.11.03.11.10
1 more packages
moodle BitnamiFrom 3.9.73.9.8, 3.10.5, 3.11.1

Products include Fedoraproject Fedora, Moodle Moodle.

How do I fix CVE-2021-36568?

Upgrade moodle/moodle to 3.11.10 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2021-36568 being exploited?

There is no known exploitation of CVE-2021-36568 in the wild and no public exploit code.

All Fedoraproject Fedora vulnerabilities

Sources

Also known as BIT-moodle-2021-36568, GHSA-fm6m-fg23-67jq, UBUNTU-CVE-2021-36568.

Is CVE-2021-36568 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free