# CVE-2021-36568: Moodle Cross-site Scripting vulnerability

> Stored XSS in Moodle database activity fields allows attackers to inject scripts, potentially leading to session hijacking or code execution.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Sep 2022
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-moodle-2021-36568, GHSA-fm6m-fg23-67jq, UBUNTU-CVE-2021-36568

## What is CVE-2021-36568?

CVE-2021-36568 is a medium-severity cross-site scripting vulnerability in Fedoraproject Fedora, published on 13 Sep 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

In certain Moodle products after creating a course, it is possible to add in a arbitrary "Topic" a resource, in this case a "Database" with the type "Text" where its values "Field name" and "Field description" are vulnerable to Cross Site Scripting Stored(XSS). This affects Moodle 3.11 and Moodle 3.10.4 and Moodle 3.9.7.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-36568?

7 open source packages ship an affected version, including moodle/moodle and moodle. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle/moodle` | Packagist | All versions to 3.9.7 | None |
| `moodle/moodle` | Packagist | All versions to 3.9.7 | None |
| `moodle/moodle` | Packagist | From 3.10.0 to 3.10.4 | None |
| `moodle/moodle` | Packagist | From 3.10.0 to 3.10.4 | None |
| `moodle/moodle` | Packagist | From 3.11.0 | 3.11.10 |
| `moodle/moodle` | Packagist | From 3.11.0 | 3.11.10 |
| `moodle` | Bitnami | From 3.9.7 | 3.9.8, 3.10.5, 3.11.1 |

Products: Fedoraproject Fedora, Moodle Moodle.

## How do I fix CVE-2021-36568?

Upgrade moodle/moodle to 3.11.10 or later.

## Is CVE-2021-36568 being exploited?

There is no known exploitation of CVE-2021-36568 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-36568 and fix it if it is affected.

What it is: CVE-2021-36568 is a medium-severity cross-site scripting vulnerability in Fedoraproject Fedora, published on 13 Sep 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-36568 in the wild and no public exploit code.

Affected packages and fixed versions:
- moodle/moodle (Packagist): affected all versions up to 3.9.7; no fix listed
- moodle/moodle (Packagist): affected all versions up to 3.9.7; no fix listed
- moodle/moodle (Packagist): affected from 3.10.0 up to 3.10.4; no fix listed
- moodle/moodle (Packagist): affected from 3.10.0 up to 3.10.4; no fix listed
- moodle/moodle (Packagist): affected from 3.11.0; fixed in 3.11.10
- moodle/moodle (Packagist): affected from 3.11.0; fixed in 3.11.10
- moodle (Bitnami): affected from 3.9.7; fixed in 3.9.8, 3.10.5, 3.11.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-36568/ (Markdown: https://insights.sbomify.com/CVE-2021-36568/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-36568
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-36568
- OSV: https://osv.dev/vulnerability/CVE-2021-36568

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-36568/
Summaries are generated and may contain mistakes; the official description above is the record.
