# CVE-2021-36711: Octobot mishandles Tentacles upload

> Remote attackers can execute arbitrary code on OctoBot instances by exploiting improper handling of Tentacles file uploads.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jul 2022
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-fr75-x856-q6j8, PYSEC-2022-235

## What is CVE-2021-36711?

CVE-2021-36711 is a critical vulnerability in n/a, published on 16 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

WebInterface in OctoBot before 0.4.4 allows remote code execution because Tentacles upload is mishandled.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2021-36711?

3 open source packages ship an affected version, including octobot and OctoBot. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `octobot` | PyPI | All versions | 0.4.4 |
| `octobot` | PyPI | All versions | 0.4.4 |
| `OctoBot` | PyPI | All versions | 0.4.4 |

Products: Octobot Octobot.

## How do I fix CVE-2021-36711?

Upgrade octobot to 0.4.4 or later.

## Is CVE-2021-36711 being exploited?

There is no known exploitation of CVE-2021-36711 in the wild and no public exploit code.

Public exploit code:

- OctoBot WebInterface 0.4.3 - Remote Code Execution (RCE) (exploitdb)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-36711 and fix it if it is affected.

What it is: CVE-2021-36711 is a critical vulnerability in n/a, published on 16 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-36711 in the wild and no public exploit code.

Affected packages and fixed versions:
- octobot (PyPI): affected all versions; fixed in 0.4.4
- octobot (PyPI): affected all versions; fixed in 0.4.4
- OctoBot (PyPI): affected all versions; fixed in 0.4.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-36711/ (Markdown: https://insights.sbomify.com/CVE-2021-36711/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-36711
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-36711
- OSV: https://osv.dev/vulnerability/CVE-2021-36711

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-36711/
Summaries are generated and may contain mistakes; the official description above is the record.
