# CVE-2021-36737: XSS in V3 Demo Portlet


- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 6 Jan 2022
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-x588-g38j-f672

## What is CVE-2021-36737?

CVE-2021-36737 is a medium-severity vulnerability in Apache Portals, published on 6 Jan 2022. 

### Official description

The input fields of the Apache Pluto UrlTestPortlet are vulnerable to Cross-Site Scripting (XSS) attacks. Users should migrate to version 3.1.1 of the v3-demo-portlet.war artifact

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-36737?

2 open source packages ship an affected version, including org.apache.portals.pluto:pluto-portal. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.portals.pluto:pluto-portal` | Maven | All versions | 3.1.1 |
| `org.apache.portals.pluto:pluto-portal` | Maven | All versions | 3.1.1 |

Products: Apache Pluto.

## How do I fix CVE-2021-36737?

Upgrade org.apache.portals.pluto:pluto-portal to 3.1.1 or later.

## Is CVE-2021-36737 being exploited?

There is no known exploitation of CVE-2021-36737 in the wild and no public exploit code.

## Other vulnerabilities in Apache Portals

- [CVE-2018-1306](https://insights.sbomify.com/CVE-2018-1306/): Exposure of Sensitive Information in Apache Pluto (high 7.5)
- [CVE-2021-36738](https://insights.sbomify.com/CVE-2021-36738/): XSS vulnerability in the JSP version of the Apache Pluto Applicant MVCBean CDI portlet (medium 6.1)
- [CVE-2021-36739](https://insights.sbomify.com/CVE-2021-36739/): XSS vulnerability in the MVCBean JSP portlet maven archetype (medium 6.1)
- [CVE-2019-0186](https://insights.sbomify.com/CVE-2019-0186/): Cross-site Scripting in Apache Pluto Chatroom demo (medium 6.1)
- [CVE-2020-15250](https://insights.sbomify.com/CVE-2020-15250/): Information disclosure in JUnit4 (medium 4.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-36737 and fix it if it is affected.

What it is: CVE-2021-36737 is a medium-severity vulnerability in Apache Portals, published on 6 Jan 2022. 
Exploitation: There is no known exploitation of CVE-2021-36737 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.portals.pluto:pluto-portal (Maven): affected all versions; fixed in 3.1.1
- org.apache.portals.pluto:pluto-portal (Maven): affected all versions; fixed in 3.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-36737/ (Markdown: https://insights.sbomify.com/CVE-2021-36737/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-36737
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-36737
- OSV: https://osv.dev/vulnerability/CVE-2021-36737

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-36737/
Summaries are generated and may contain mistakes; the official description above is the record.
