# CVE-2021-36753: Uncontrolled Search Path Element in sharkdp/bat

> Attackers can execute arbitrary code by placing a malicious less.exe in the current working directory when using BAT.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jul 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-p24j-h477-76q3, RUSTSEC-2021-0106

## What is CVE-2021-36753?

CVE-2021-36753 is a high-severity path traversal vulnerability in n/a, published on 15 Jul 2021. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

sharkdp BAT before 0.18.2 executes less.exe from the current working directory.

Weakness: CWE-427 (Uncontrolled Search Path Element)

## Which versions are affected by CVE-2021-36753?

3 open source packages ship an affected version, including bat. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bat` | crates.io | All versions | 0.18.2 |
| `bat` | crates.io | All versions | 0.18.2 |
| `bat` | crates.io | From 0.0.0-0 | 0.18.2 |

Products: Bat Project Bat.

## How do I fix CVE-2021-36753?

Upgrade bat to 0.18.2 or later.

## Is CVE-2021-36753 being exploited?

There is no known exploitation of CVE-2021-36753 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-36753 and fix it if it is affected.

What it is: CVE-2021-36753 is a high-severity path traversal vulnerability in n/a, published on 15 Jul 2021. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-36753 in the wild and no public exploit code.

Affected packages and fixed versions:
- bat (crates.io): affected all versions; fixed in 0.18.2
- bat (crates.io): affected all versions; fixed in 0.18.2
- bat (crates.io): affected from 0.0.0-0; fixed in 0.18.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-36753/ (Markdown: https://insights.sbomify.com/CVE-2021-36753/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-36753
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-36753
- OSV: https://osv.dev/vulnerability/CVE-2021-36753

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-36753/
Summaries are generated and may contain mistakes; the official description above is the record.
