# CVE-2021-36775: Deleting PRTBs associated to a group doesn't cause deletion of corresponding RoleBindings

> Attackers retain revoked privileges because deleting Project Role Template Bindings fails to remove associated RoleBindings in SUSE Rancher.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Apr 2022
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-28g7-896h-695v, GO-2024-2760

## What is CVE-2021-36775?

CVE-2021-36775 is a high-severity missing authorization vulnerability in SUSE Rancher, published on 1 Apr 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

a Improper Access Control vulnerability in SUSE Rancher allows users to keep privileges that should have been revoked. This issue affects: SUSE Rancher Rancher versions prior to 2.4.18; Rancher versions prior to 2.5.12; Rancher versions prior to 2.6.3.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2021-36775?

7 open source packages ship an affected version, including github.com/rancher/rancher. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/rancher/rancher` | Go | All versions | None |
| `github.com/rancher/rancher` | Go | All versions | 2.4.18 |
| `github.com/rancher/rancher` | Go | All versions | 2.4.18 |
| `github.com/rancher/rancher` | Go | From 2.5.0 | 2.5.12 |
| `github.com/rancher/rancher` | Go | From 2.5.0 | 2.5.12 |
| `github.com/rancher/rancher` | Go | From 2.6.0 | 2.6.3 |
| `github.com/rancher/rancher` | Go | From 2.6.0 | 2.6.3 |

Products: Rancher Rancher.

## How do I fix CVE-2021-36775?

Upgrade github.com/rancher/rancher to a fixed version for your release line: 2.4.18, 2.5.12 or 2.6.3.

## Is CVE-2021-36775 being exploited?

There is no known exploitation of CVE-2021-36775 in the wild and no public exploit code.

## Other vulnerabilities in SUSE Rancher

- [CVE-2021-25320](https://insights.sbomify.com/CVE-2021-25320/): Rancher: Cloud credentials can be used through proxy API by users without access (critical 9.9)
- [CVE-2021-36776](https://insights.sbomify.com/CVE-2021-36776/): Steve API proxy impersonation (high 8.8)
- [CVE-2021-25318](https://insights.sbomify.com/CVE-2021-25318/): rancher: API group not properly specified when creating Kubernetes RBAC resources (high 8.8)
- [CVE-2021-31999](https://insights.sbomify.com/CVE-2021-31999/): Rancher: Privilege escalation vulnerability via malicious Connection header (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-36775 and fix it if it is affected.

What it is: CVE-2021-36775 is a high-severity missing authorization vulnerability in SUSE Rancher, published on 1 Apr 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-36775 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/rancher/rancher (Go): affected all versions; no fix listed
- github.com/rancher/rancher (Go): affected all versions; fixed in 2.4.18
- github.com/rancher/rancher (Go): affected all versions; fixed in 2.4.18
- github.com/rancher/rancher (Go): affected from 2.5.0; fixed in 2.5.12
- github.com/rancher/rancher (Go): affected from 2.5.0; fixed in 2.5.12
- github.com/rancher/rancher (Go): affected from 2.6.0; fixed in 2.6.3
- github.com/rancher/rancher (Go): affected from 2.6.0; fixed in 2.6.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-36775/ (Markdown: https://insights.sbomify.com/CVE-2021-36775/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-36775
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-36775
- OSV: https://osv.dev/vulnerability/CVE-2021-36775

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-36775/
Summaries are generated and may contain mistakes; the official description above is the record.
