{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-36781 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2021-36781 is a medium-severity vulnerability in openSUSE Factory, published on 14 Jan 2022. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-36781 and fix it if it is affected.\n\nWhat it is: CVE-2021-36781 is a medium-severity vulnerability in openSUSE Factory, published on 14 Jan 2022. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-36781 in the wild and no public exploit code.\n\nAffected product: openSUSE Factory. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-36781/ (Markdown: https://insights.sbomify.com/CVE-2021-36781/index.md)","id":"CVE-2021-36781","markdown":"https://insights.sbomify.com/CVE-2021-36781/index.md","name":"CVE-2021-36781","record":{"aliases":["GHSA-m398-vv9j-2r7f","openSUSE-SU-2024:11665-1"],"analysis":{"component_type":"operating_system","fix_type":"upgrade","impacts":["denial_of_service","security_bypass"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"openSUSE parsec package","requires_auth":"none","summary":"Local attackers can exploit insecure default permissions to impersonate the parsec service, causing denial of service or client hijacking.","user_interaction":"not_required","vuln_class":"misconfiguration"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"suse","cpe":[{"product":"factory","vendor":"opensuse"}],"cvss":{"score":5.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-276","name":"Incorrect Default Permissions"}],"description":"A Incorrect Default Permissions vulnerability in the parsec package of openSUSE Factory allows local attackers to imitate the service leading to DoS or clients talking to an imposter service. This issue affects: openSUSE Factory parsec versions prior to 0.8.1-1.1.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"parsec: dangerous 777 permissions for /run/parsec","id":"CVE-2021-36781","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"misconfiguration","year":"2021"},"n_packages":1,"n_references":1,"next":{"headline":"Rancher: Plaintext storage and exposure of credentials in Rancher API and cluster.management.cattle.io object","id":"CVE-2021-36782"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["0.8.0-3.1"],"introduced":["0"],"last_affected":[],"package":"parsec","purl":"pkg:rpm/opensuse/parsec\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:11665-1"}],"prev":{"headline":"Unauthorized data access from replicas through vulnerable instance manager pods","id":"CVE-2021-36780"},"products":["Factory"],"published":"2022-01-14","related":[{"cvss_score":7.8,"headline":"virtualbox: missing sticky bit for /etc/vbox allows local root exploit for members of vboxusers group","id":"CVE-2021-25319","kev_date_added":null,"published":"2021-05-05"},{"cvss_score":7.7,"headline":"sendmail: mail to root privilege escalation via sm-client.pre script","id":"CVE-2022-31256","kev_date_added":null,"published":"2022-10-26"},{"cvss_score":6.5,"headline":"slurm: %post for slurm-testsuite operates as root in user owned directory","id":"CVE-2022-31251","kev_date_added":null,"published":"2022-09-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["openSUSE"]},"summary":"Local attackers can exploit insecure default permissions to impersonate the parsec service, causing denial of service or client hijacking.","url":"https://insights.sbomify.com/CVE-2021-36781/"}