# CVE-2021-36782: Rancher: Plaintext storage and exposure of credentials in Rancher API and cluster.management.cattle.io object

> Authenticated users can retrieve plaintext sensitive credentials via the Kubernetes API, exposing secrets to unauthorized parties.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Sep 2022
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-g7j7-h4q8-8w2f

## What is CVE-2021-36782?

CVE-2021-36782 is a critical vulnerability in SUSE Rancher, published on 7 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A Cleartext Storage of Sensitive Information vulnerability in SUSE Rancher allows authenticated Cluster Owners, Cluster Members, Project Owners, Project Members and User Base to use the Kubernetes API to retrieve plaintext version of sensitive data. This issue affects: SUSE Rancher Rancher versions prior to 2.5.16; Rancher versions prior to 2.6.7.

Weakness: CWE-312 (Cleartext Storage of Sensitive Information)

## Which versions are affected by CVE-2021-36782?

4 open source packages ship an affected version, including github.com/rancher/rancher. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/rancher/rancher` | Go | From 2.5.0 | 2.5.16 |
| `github.com/rancher/rancher` | Go | From 2.5.0 | 2.5.16 |
| `github.com/rancher/rancher` | Go | From 2.6.0 | 2.6.7 |
| `github.com/rancher/rancher` | Go | From 2.6.0 | 2.6.7 |

Products: Suse Rancher.

## How do I fix CVE-2021-36782?

Upgrade github.com/rancher/rancher to a fixed version for your release line: 2.5.16 or 2.6.7.

## Is CVE-2021-36782 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-36782 exists.

Public exploit code:

- Rancher Authenticated API Credential Exposure (metasploit)
- A Terraform module to launch Rancher 2.6.6 for blog article about CVE-2021-36782 (github_poc): https://github.com/fe-ax/tf-cve-2021-36782

## Other vulnerabilities in SUSE Rancher

- [CVE-2023-22647](https://insights.sbomify.com/CVE-2023-22647/): Rancher vulnerable to Privilege Escalation via manipulation of Secrets (critical 9.9)
- [CVE-2023-22651](https://insights.sbomify.com/CVE-2023-22651/): Rancher Webhook is misconfigured during upgrade process (critical 9.9)
- [CVE-2022-43757](https://insights.sbomify.com/CVE-2022-43757/): Rancher: Exposure of sensitive fields (critical 9.9)
- [CVE-2021-36783](https://insights.sbomify.com/CVE-2021-36783/): Rancher: Failure to properly sanitize credentials in cluster template answers (critical 9.9)
- [CVE-2019-11202](https://insights.sbomify.com/CVE-2019-11202/): Rancher Recreates Default User With Known Password Despite Deletion (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-36782 and fix it if it is affected.

What it is: CVE-2021-36782 is a critical vulnerability in SUSE Rancher, published on 7 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-36782 exists.

Affected packages and fixed versions:
- github.com/rancher/rancher (Go): affected from 2.5.0; fixed in 2.5.16
- github.com/rancher/rancher (Go): affected from 2.5.0; fixed in 2.5.16
- github.com/rancher/rancher (Go): affected from 2.6.0; fixed in 2.6.7
- github.com/rancher/rancher (Go): affected from 2.6.0; fixed in 2.6.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-36782/ (Markdown: https://insights.sbomify.com/CVE-2021-36782/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-36782
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-36782
- OSV: https://osv.dev/vulnerability/CVE-2021-36782

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-36782/
Summaries are generated and may contain mistakes; the official description above is the record.
