# CVE-2021-36786: Sensitive Data Exposure in miniorange_saml

> An attacker can expose sensitive API credentials and private keys via the Miniorange SAML extension for TYPO3.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Aug 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-g485-29gq-6h2h

## What is CVE-2021-36786?

CVE-2021-36786 is a high-severity vulnerability in n/a, published on 13 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The miniorange_saml (aka Miniorange Saml) extension before 1.4.3 for TYPO3 allows Sensitive Data Exposure of API credentials and private keys.

Weakness: CWE-922 (Insecure Storage of Sensitive Information)

## Which versions are affected by CVE-2021-36786?

2 open source packages ship an affected version, including miniorange/miniorange-saml. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `miniorange/miniorange-saml` | Packagist | All versions | 1.4.3 |
| `miniorange/miniorange-saml` | Packagist | All versions | 1.4.3 |

Products: Miniorange Saml.

## How do I fix CVE-2021-36786?

Upgrade miniorange/miniorange-saml to 1.4.3 or later.

## Is CVE-2021-36786 being exploited?

There is no known exploitation of CVE-2021-36786 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-36785](https://insights.sbomify.com/CVE-2021-36785/): Cross-site Scripting in TYPO3 extension (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-36786 and fix it if it is affected.

What it is: CVE-2021-36786 is a high-severity vulnerability in n/a, published on 13 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-36786 in the wild and no public exploit code.

Affected packages and fixed versions:
- miniorange/miniorange-saml (Packagist): affected all versions; fixed in 1.4.3
- miniorange/miniorange-saml (Packagist): affected all versions; fixed in 1.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-36786/ (Markdown: https://insights.sbomify.com/CVE-2021-36786/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-36786
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-36786
- OSV: https://osv.dev/vulnerability/CVE-2021-36786

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-36786/
Summaries are generated and may contain mistakes; the official description above is the record.
