CVE-2021-36788 Cross-site Scripting in the yoast_seo TYPO3 extension
Cross-site scripting vulnerability in the Yoast SEO extension for TYPO3 allows attackers to inject malicious scripts.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-36788?
CVE-2021-36788 is a medium-severity cross-site scripting vulnerability in n/a, published on 13 Aug 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
The yoast_seo (aka Yoast SEO) extension before 7.2.3 for TYPO3 allows XSS.
Weakness: CWE-79
Which versions are affected by CVE-2021-36788?
2 open source packages ship an affected version, including yoast-seo-for-typo3/yoast_seo. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
yoast-seo-for-typo3/yoast_seo Packagist | All versions | 7.2.3 |
yoast-seo-for-typo3/yoast_seo Packagist | All versions | 7.2.3 |
Products include Yoast Yoast Seo.
How do I fix CVE-2021-36788?
Upgrade yoast-seo-for-typo3/yoast_seo to 7.2.3 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2021-36788 being exploited?
There is no known exploitation of CVE-2021-36788 in the wild and no public exploit code.
Other vulnerabilities in n/a
- CVE-2019-13478 Cross-site scripting in n/a
- CVE-2023-32300 WordPress Yoast SEO: Local Plugin <= 14.8 is vulnerable to Cross Site Scripting (XSS)
- CVE-2018-19370 Race condition in n/a
- CVE-2023-28785 WordPress Yoast SEO: Local Plugin <= 14.9 is vulnerable to Cross Site Scripting (XSS)
- CVE-2021-31779 Server-Side Request Forgery in yoast_seo
Sources
Also known as GHSA-28w5-j8xj-2xwc.