{"answers":{"affected":"2 open source packages ship an affected version, including yoast-seo-for-typo3/yoast_seo. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-36788 in the wild and no public exploit code.","fix":"Upgrade yoast-seo-for-typo3/yoast_seo to 7.2.3 or later.","what":"CVE-2021-36788 is a medium-severity cross-site scripting vulnerability in n/a, published on 13 Aug 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-36788 and fix it if it is affected.\n\nWhat it is: CVE-2021-36788 is a medium-severity cross-site scripting vulnerability in n/a, published on 13 Aug 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-36788 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- yoast-seo-for-typo3/yoast_seo (Packagist): affected all versions; fixed in 7.2.3\n- yoast-seo-for-typo3/yoast_seo (Packagist): affected all versions; fixed in 7.2.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-36788/ (Markdown: https://insights.sbomify.com/CVE-2021-36788/index.md)","id":"CVE-2021-36788","markdown":"https://insights.sbomify.com/CVE-2021-36788/index.md","name":"CVE-2021-36788","record":{"aliases":["GHSA-28w5-j8xj-2xwc"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"TYPO3 SEO plugin","requires_auth":"low_privilege","summary":"Cross-site scripting vulnerability in the Yoast SEO extension for TYPO3 allows attackers to inject malicious scripts.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"yoast_seo","vendor":"yoast"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The yoast_seo (aka Yoast SEO) extension before 7.2.3 for TYPO3 allows XSS.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site Scripting in the yoast_seo TYPO3 extension","id":"CVE-2021-36788","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2021"},"n_packages":2,"n_references":2,"next":{"headline":"SQL injection in n/a","id":"CVE-2021-36789"},"packages":[{"ecosystem":"Packagist","fixed":["7.2.3"],"introduced":["0"],"last_affected":[],"package":"yoast-seo-for-typo3/yoast_seo","purl":null,"source":"GHSA-28w5-j8xj-2xwc"},{"ecosystem":"Packagist","fixed":["7.2.3"],"introduced":["0"],"last_affected":[],"package":"yoast-seo-for-typo3/yoast_seo","purl":"pkg:composer/yoast-seo-for-typo3/yoast_seo","source":"GHSA-28w5-j8xj-2xwc"}],"prev":{"headline":"Cross-site Scripting in the femanager TYPO3 extension","id":"CVE-2021-36787"},"products":["n/a"],"published":"2021-08-13","related":[{"cvss_score":9.9,"headline":"Cross-site scripting in n/a","id":"CVE-2019-13478","kev_date_added":null,"published":"2019-07-09"},{"cvss_score":7.1,"headline":"WordPress Yoast SEO: Local Plugin \u003c= 14.8 is vulnerable to Cross Site Scripting (XSS)","id":"CVE-2023-32300","kev_date_added":null,"published":"2023-08-23"},{"cvss_score":6.6,"headline":"Race condition in n/a","id":"CVE-2018-19370","kev_date_added":null,"published":"2018-11-28"},{"cvss_score":6.5,"headline":"WordPress Yoast SEO: Local Plugin \u003c= 14.9 is vulnerable to Cross Site Scripting (XSS)","id":"CVE-2023-28785","kev_date_added":null,"published":"2023-05-28"},{"cvss_score":6.4,"headline":"Server-Side Request Forgery in yoast_seo","id":"CVE-2021-31779","kev_date_added":null,"published":"2021-04-28"},{"cvss_score":5.9,"headline":"WordPress Yoast SEO Plugin \u003c= 21.0 is vulnerable to Cross Site Scripting (XSS)","id":"CVE-2023-40680","kev_date_added":null,"published":"2023-11-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Cross-site scripting vulnerability in the Yoast SEO extension for TYPO3 allows attackers to inject malicious scripts.","url":"https://insights.sbomify.com/CVE-2021-36788/"}