# CVE-2021-36793: CSRF token exposure in TYPO3 extension

> An attacker can obtain sensitive session identifiers from HTML output in the TYPO3 Extbase Yaml Routes extension when the CsrfTokenViewHelper is used.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Aug 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-vpw5-grxx-v396

## What is CVE-2021-36793?

CVE-2021-36793 is a high-severity vulnerability in n/a, published on 13 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The routes (aka Extbase Yaml Routes) extension before 2.1.1 for TYPO3, when CsrfTokenViewHelper is used, allows Sensitive Information Disclosure because a session identifier is unsafely present in HTML output.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2021-36793?

2 open source packages ship an affected version, including lms/routes. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lms/routes` | Packagist | All versions | 2.1.1 |
| `lms/routes` | Packagist | All versions | 2.1.1 |

Products: Routes Project Routes.

## How do I fix CVE-2021-36793?

Upgrade lms/routes to 2.1.1 or later.

## Is CVE-2021-36793 being exploited?

There is no known exploitation of CVE-2021-36793 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-36793 and fix it if it is affected.

What it is: CVE-2021-36793 is a high-severity vulnerability in n/a, published on 13 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-36793 in the wild and no public exploit code.

Affected packages and fixed versions:
- lms/routes (Packagist): affected all versions; fixed in 2.1.1
- lms/routes (Packagist): affected all versions; fixed in 2.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-36793/ (Markdown: https://insights.sbomify.com/CVE-2021-36793/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-36793
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-36793
- OSV: https://osv.dev/vulnerability/CVE-2021-36793

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-36793/
Summaries are generated and may contain mistakes; the official description above is the record.
