{"answers":{"affected":"3 open source packages ship an affected version, including ansible-runner. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-3701 in the wild and no public exploit code.","fix":"Upgrade ansible-runner to 2.1.0 or later.","what":"CVE-2021-3701 is a medium-severity vulnerability in ansible-runner, published on 23 Aug 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-3701 and fix it if it is affected.\n\nWhat it is: CVE-2021-3701 is a medium-severity vulnerability in ansible-runner, published on 23 Aug 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-3701 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ansible-runner (PyPI): affected from 2.0.0; fixed in 2.1.0\n- ansible-runner (PyPI): affected from 2.0.0; fixed in 2.1.0\n- ansible-runner (PyPI): affected from 2.0.0; fixed in 2.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-3701/ (Markdown: https://insights.sbomify.com/CVE-2021-3701/index.md)","id":"CVE-2021-3701","markdown":"https://insights.sbomify.com/CVE-2021-3701/index.md","name":"CVE-2021-3701","record":{"aliases":["DEBIAN-CVE-2021-3701","GHSA-wwch-cmqr-hhrm","PYSEC-2022-43067"],"analysis":{"component_type":"developer_tool","fix_type":"patch","impacts":["data_read","data_modify"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Ansible Runner","requires_auth":"low_privilege","summary":"An attacker can read private information or force file writes by pre-creating directories in world-writable temporary locations used by Ansible Runner.","user_interaction":"required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"ansible_runner","vendor":"redhat"}],"cvss":{"score":6.6,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-276","name":"Incorrect Default Permissions"}],"description":"A flaw was found in ansible-runner where the default temporary files configuration in ansible-2.0.0 are written to world R/W locations. This flaw allows an attacker to pre-create the directory, resulting in reading private information or forcing ansible-runner to write files as the legitimate user in a place they did not expect. The highest threat from this vulnerability is to confidentiality and integrity.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"ansible-runner has default temporary files written to world R/W locations","id":"CVE-2021-3701","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"information_disclosure","year":"2021"},"n_packages":3,"n_references":4,"next":{"headline":"ansible-runner vulnerable to Race Condition","id":"CVE-2021-3702"},"packages":[{"ecosystem":"PyPI","fixed":["2.1.0"],"introduced":["2.0.0"],"last_affected":[],"package":"ansible-runner","purl":null,"source":"GHSA-wwch-cmqr-hhrm"},{"ecosystem":"PyPI","fixed":["2.1.0"],"introduced":["2.0.0"],"last_affected":[],"package":"ansible-runner","purl":"pkg:pypi/ansible-runner","source":"GHSA-wwch-cmqr-hhrm"},{"ecosystem":"PyPI","fixed":["2.1.0"],"introduced":["2.0.0"],"last_affected":[],"package":"ansible-runner","purl":"pkg:pypi/ansible-runner","source":"PYSEC-2022-43067"}],"prev":{"headline":"Use after free in usbredir","id":"CVE-2021-3700"},"products":["ansible-runner"],"published":"2022-08-23","related":[{"cvss_score":7.8,"headline":"ansible-runner vulnerable to shell command injection","id":"CVE-2021-4041","kev_date_added":null,"published":"2022-08-24"},{"cvss_score":6.3,"headline":"ansible-runner vulnerable to Race Condition","id":"CVE-2021-3702","kev_date_added":null,"published":"2022-08-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"An attacker can read private information or force file writes by pre-creating directories in world-writable temporary locations used by Ansible Runner.","url":"https://insights.sbomify.com/CVE-2021-3701/"}