# CVE-2021-3702: ansible-runner vulnerable to Race Condition

> An attacker can exploit a race condition in ansible-runner to substitute a temporary directory, gaining unauthorized access to private data.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Aug 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-772j-xvf9-qpf5, PYSEC-2022-43068

## What is CVE-2021-3702?

CVE-2021-3702 is a medium-severity vulnerability in ansible-runner, published on 23 Aug 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A race condition flaw was found in ansible-runner, where an attacker could watch for rapid creation and deletion of a temporary directory, substitute their directory at that name, and then have access to ansible-runner's private_data_dir the next time ansible-runner made use of the private_data_dir. The highest Threat out of this flaw is to integrity and confidentiality.

Weakness: CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization)

## Which versions are affected by CVE-2021-3702?

3 open source packages ship an affected version, including ansible-runner. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ansible-runner` | PyPI | From 2.0.0 | 2.1.0 |
| `ansible-runner` | PyPI | From 2.0.0 | 2.1.0 |
| `ansible-runner` | PyPI | From 2.0.0 | 2.1.0 |

Products: Redhat Ansible Runner.

## How do I fix CVE-2021-3702?

Upgrade ansible-runner to 2.1.0 or later.

## Is CVE-2021-3702 being exploited?

There is no known exploitation of CVE-2021-3702 in the wild and no public exploit code.

## Other vulnerabilities in ansible-runner

- [CVE-2021-4041](https://insights.sbomify.com/CVE-2021-4041/): ansible-runner vulnerable to shell command injection (high 7.8)
- [CVE-2021-3701](https://insights.sbomify.com/CVE-2021-3701/): ansible-runner has default temporary files written to world R/W locations (medium 6.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-3702 and fix it if it is affected.

What it is: CVE-2021-3702 is a medium-severity vulnerability in ansible-runner, published on 23 Aug 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-3702 in the wild and no public exploit code.

Affected packages and fixed versions:
- ansible-runner (PyPI): affected from 2.0.0; fixed in 2.1.0
- ansible-runner (PyPI): affected from 2.0.0; fixed in 2.1.0
- ansible-runner (PyPI): affected from 2.0.0; fixed in 2.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-3702/ (Markdown: https://insights.sbomify.com/CVE-2021-3702/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-3702
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-3702
- OSV: https://osv.dev/vulnerability/CVE-2021-3702

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-3702/
Summaries are generated and may contain mistakes; the official description above is the record.
