CVE-2021-37404 Heap buffer overflow in libhdfs native library

Critical 9.8 Published Updated

Heap buffer overflow in libhdfs allows attackers to cause denial of service or execute arbitrary code via unvalidated file paths.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-37404?

CVE-2021-37404 is a critical memory corruption vulnerability in Apache Hadoop, published on 13 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

There is a potential heap buffer overflow in Apache Hadoop libhdfs native code. Opening a file path provided by user without validation may result in a denial of service or arbitrary code execution. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.

Weakness: CWE-787

Which versions are affected by CVE-2021-37404?

6 open source packages ship an affected version, including org.apache.hadoop:hadoop-common. It affects 1 product.

PackageAffectedFixed in
org.apache.hadoop:hadoop-common MavenAll versions2.10.2
org.apache.hadoop:hadoop-common MavenAll versions2.10.2
org.apache.hadoop:hadoop-common MavenFrom 3.0.03.2.3
org.apache.hadoop:hadoop-common MavenFrom 3.0.03.2.3
org.apache.hadoop:hadoop-common MavenFrom 3.3.03.3.2
org.apache.hadoop:hadoop-common MavenFrom 3.3.03.3.2

Products include Apache Hadoop.

How do I fix CVE-2021-37404?

Upgrade org.apache.hadoop:hadoop-common to a fixed version for your release line: 2.10.2, 3.2.3 or 3.3.2.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2021-37404 being exploited?

There is no known exploitation of CVE-2021-37404 in the wild and no public exploit code.

Sources

Also known as GHSA-rmpj-7c96-mrg8.

Is CVE-2021-37404 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free