{"answers":{"affected":"6 open source packages ship an affected version, including org.apache.hadoop:hadoop-common. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-37404 in the wild and no public exploit code.","fix":"Upgrade org.apache.hadoop:hadoop-common to a fixed version for your release line: 2.10.2, 3.2.3 or 3.3.2.","what":"CVE-2021-37404 is a critical memory corruption vulnerability in Apache Hadoop, published on 13 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-37404 and fix it if it is affected.\n\nWhat it is: CVE-2021-37404 is a critical memory corruption vulnerability in Apache Hadoop, published on 13 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-37404 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.hadoop:hadoop-common (Maven): affected all versions; fixed in 2.10.2\n- org.apache.hadoop:hadoop-common (Maven): affected all versions; fixed in 2.10.2\n- org.apache.hadoop:hadoop-common (Maven): affected from 3.0.0; fixed in 3.2.3\n- org.apache.hadoop:hadoop-common (Maven): affected from 3.0.0; fixed in 3.2.3\n- org.apache.hadoop:hadoop-common (Maven): affected from 3.3.0; fixed in 3.3.2\n- org.apache.hadoop:hadoop-common (Maven): affected from 3.3.0; fixed in 3.3.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-37404/ (Markdown: https://insights.sbomify.com/CVE-2021-37404/index.md)","id":"CVE-2021-37404","markdown":"https://insights.sbomify.com/CVE-2021-37404/index.md","name":"CVE-2021-37404","record":{"aliases":["GHSA-rmpj-7c96-mrg8"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Hadoop libhdfs library","requires_auth":"none","summary":"Heap buffer overflow in libhdfs allows attackers to cause denial of service or execute arbitrary code via unvalidated file paths.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"hadoop","vendor":"apache"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"}],"description":"There is a potential heap buffer overflow in Apache Hadoop libhdfs native code. Opening a file path provided by user without validation may result in a denial of service or arbitrary code execution. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Heap buffer overflow in libhdfs native library","id":"CVE-2021-37404","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"memory_corruption","year":"2021"},"n_packages":6,"n_references":2,"next":{"headline":"This is unused.","id":"CVE-2021-37405"},"packages":[{"ecosystem":"Maven","fixed":["2.10.2"],"introduced":["0"],"last_affected":[],"package":"org.apache.hadoop:hadoop-common","purl":null,"source":"GHSA-rmpj-7c96-mrg8"},{"ecosystem":"Maven","fixed":["2.10.2"],"introduced":["0"],"last_affected":[],"package":"org.apache.hadoop:hadoop-common","purl":"pkg:maven/org.apache.hadoop/hadoop-common","source":"GHSA-rmpj-7c96-mrg8"},{"ecosystem":"Maven","fixed":["3.2.3"],"introduced":["3.0.0"],"last_affected":[],"package":"org.apache.hadoop:hadoop-common","purl":null,"source":"GHSA-rmpj-7c96-mrg8"},{"ecosystem":"Maven","fixed":["3.2.3"],"introduced":["3.0.0"],"last_affected":[],"package":"org.apache.hadoop:hadoop-common","purl":"pkg:maven/org.apache.hadoop/hadoop-common","source":"GHSA-rmpj-7c96-mrg8"},{"ecosystem":"Maven","fixed":["3.3.2"],"introduced":["3.3.0"],"last_affected":[],"package":"org.apache.hadoop:hadoop-common","purl":null,"source":"GHSA-rmpj-7c96-mrg8"},{"ecosystem":"Maven","fixed":["3.3.2"],"introduced":["3.3.0"],"last_affected":[],"package":"org.apache.hadoop:hadoop-common","purl":"pkg:maven/org.apache.hadoop/hadoop-common","source":"GHSA-rmpj-7c96-mrg8"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2021-37403"},"products":["Apache Hadoop"],"published":"2022-06-13","related":[{"cvss_score":9.8,"headline":"Command injection in org.apache.hadoop.fs.FileUtil.unTarUsingTar","id":"CVE-2022-25168","kev_date_added":null,"published":"2022-08-04"},{"cvss_score":9.8,"headline":"Arbitrary file write in FileUtil#unpackEntries on Windows","id":"CVE-2022-26612","kev_date_added":null,"published":"2022-04-07"},{"cvss_score":9.8,"headline":"Improper Check for Unusual or Exceptional Conditions in Connect2id Nimbus JOSE+JWT","id":"CVE-2019-17195","kev_date_added":null,"published":"2019-10-15"},{"cvss_score":9.8,"headline":"Exposure of Sensitive Information in Hadoop","id":"CVE-2017-15718","kev_date_added":null,"published":"2018-01-24"},{"cvss_score":9.8,"headline":"Use of a Broken or Risky Cryptographic Algorithm in Apache Hadoop","id":"CVE-2012-4449","kev_date_added":null,"published":"2017-10-30"},{"cvss_score":9.8,"headline":"Exposure of Sensitive Information to an Unauthorized Actor in Apache Hadoop","id":"CVE-2016-3086","kev_date_added":null,"published":"2017-09-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Apache Software Foundation"]},"summary":"Heap buffer overflow in libhdfs allows attackers to cause denial of service or execute arbitrary code via unvalidated file paths.","url":"https://insights.sbomify.com/CVE-2021-37404/"}