# CVE-2021-37404: Heap buffer overflow in libhdfs native library

> Heap buffer overflow in libhdfs allows attackers to cause denial of service or execute arbitrary code via unvalidated file paths.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jun 2022
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-rmpj-7c96-mrg8

## What is CVE-2021-37404?

CVE-2021-37404 is a critical memory corruption vulnerability in Apache Hadoop, published on 13 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

There is a potential heap buffer overflow in Apache Hadoop libhdfs native code. Opening a file path provided by user without validation may result in a denial of service or arbitrary code execution. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2021-37404?

6 open source packages ship an affected version, including org.apache.hadoop:hadoop-common. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.hadoop:hadoop-common` | Maven | All versions | 2.10.2 |
| `org.apache.hadoop:hadoop-common` | Maven | All versions | 2.10.2 |
| `org.apache.hadoop:hadoop-common` | Maven | From 3.0.0 | 3.2.3 |
| `org.apache.hadoop:hadoop-common` | Maven | From 3.0.0 | 3.2.3 |
| `org.apache.hadoop:hadoop-common` | Maven | From 3.3.0 | 3.3.2 |
| `org.apache.hadoop:hadoop-common` | Maven | From 3.3.0 | 3.3.2 |

Products: Apache Hadoop.

## How do I fix CVE-2021-37404?

Upgrade org.apache.hadoop:hadoop-common to a fixed version for your release line: 2.10.2, 3.2.3 or 3.3.2.

## Is CVE-2021-37404 being exploited?

There is no known exploitation of CVE-2021-37404 in the wild and no public exploit code.

## Other vulnerabilities in Apache Hadoop

- [CVE-2022-25168](https://insights.sbomify.com/CVE-2022-25168/): Command injection in org.apache.hadoop.fs.FileUtil.unTarUsingTar (critical 9.8)
- [CVE-2022-26612](https://insights.sbomify.com/CVE-2022-26612/): Arbitrary file write in FileUtil#unpackEntries on Windows (critical 9.8)
- [CVE-2019-17195](https://insights.sbomify.com/CVE-2019-17195/): Improper Check for Unusual or Exceptional Conditions in Connect2id Nimbus JOSE+JWT (critical 9.8)
- [CVE-2017-15718](https://insights.sbomify.com/CVE-2017-15718/): Exposure of Sensitive Information in Hadoop (critical 9.8)
- [CVE-2012-4449](https://insights.sbomify.com/CVE-2012-4449/): Use of a Broken or Risky Cryptographic Algorithm in Apache Hadoop (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-37404 and fix it if it is affected.

What it is: CVE-2021-37404 is a critical memory corruption vulnerability in Apache Hadoop, published on 13 Jun 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-37404 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.hadoop:hadoop-common (Maven): affected all versions; fixed in 2.10.2
- org.apache.hadoop:hadoop-common (Maven): affected all versions; fixed in 2.10.2
- org.apache.hadoop:hadoop-common (Maven): affected from 3.0.0; fixed in 3.2.3
- org.apache.hadoop:hadoop-common (Maven): affected from 3.0.0; fixed in 3.2.3
- org.apache.hadoop:hadoop-common (Maven): affected from 3.3.0; fixed in 3.3.2
- org.apache.hadoop:hadoop-common (Maven): affected from 3.3.0; fixed in 3.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-37404/ (Markdown: https://insights.sbomify.com/CVE-2021-37404/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-37404
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-37404
- OSV: https://osv.dev/vulnerability/CVE-2021-37404

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-37404/
Summaries are generated and may contain mistakes; the official description above is the record.
