{"answers":{"affected":"It affects 3 products.","exploited":"There is no known exploitation of CVE-2021-3746 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2021-3746 is a medium-severity memory corruption vulnerability in Fedoraproject Fedora, published on 19 Oct 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-3746 and fix it if it is affected.\n\nWhat it is: CVE-2021-3746 is a medium-severity memory corruption vulnerability in Fedoraproject Fedora, published on 19 Oct 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-3746 in the wild and no public exploit code.\n\nAffected product: Fedoraproject Fedora. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-3746/ (Markdown: https://insights.sbomify.com/CVE-2021-3746/index.md)","id":"CVE-2021-3746","markdown":"https://insights.sbomify.com/CVE-2021-3746/index.md","name":"CVE-2021-3746","record":{"aliases":["DEBIAN-CVE-2021-3746","GHSA-9ffq-6fp7-34mv","SUSE-SU-2021:3004-1","SUSE-SU-2021:3004-2","openSUSE-SU-2021:3004-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"TPM emulation library","requires_auth":"none","summary":"A buffer overflow in libtpms allows attackers to cause a denial of service via crafted TPM2 command packets.","user_interaction":"required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"libtpms","vendor":"libtpms_project"},{"product":"enterprise_linux","vendor":"redhat"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"A flaw was found in the libtpms code that may cause access beyond the boundary of internal buffers. The vulnerability is triggered by specially-crafted TPM2 command packets that then trigger the issue when the state of the TPM2's volatile state is written. The highest threat from this vulnerability is to system availability. This issue affects libtpms versions before 0.8.5, before 0.7.9 and before 0.6.6.","ecosystems":["SUSE:Linux Enterprise Micro 5.1","SUSE:Linux Enterprise Module for Server Applications 15 SP3","openSUSE:Leap 15.3"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Memory corruption in libtpms","id":"CVE-2021-3746","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"fedoraproject:fedora","products":["fedoraproject:fedora","redhat:enterprise_linux"],"type":"memory_corruption","year":"2021"},"n_packages":3,"n_references":1,"next":{"headline":"MacOS version of Multipass incorrect owner for application directory","id":"CVE-2021-3747"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Micro 5.1","fixed":["0.8.2-3.3.1"],"introduced":["0"],"last_affected":[],"package":"libtpms","purl":"pkg:rpm/suse/libtpms\u0026distro=SUSE%20Linux%20Enterprise%20Micro%205.1","source":"SUSE-SU-2021:3004-2"},{"ecosystem":"SUSE:Linux Enterprise Module for Server Applications 15 SP3","fixed":["0.8.2-3.3.1"],"introduced":["0"],"last_affected":[],"package":"libtpms","purl":"pkg:rpm/suse/libtpms\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Server%20Applications%2015%20SP3","source":"SUSE-SU-2021:3004-1"},{"ecosystem":"openSUSE:Leap 15.3","fixed":["0.8.2-3.3.1"],"introduced":["0"],"last_affected":[],"package":"libtpms","purl":"pkg:rpm/opensuse/libtpms\u0026distro=openSUSE%20Leap%2015.3","source":"openSUSE-SU-2021:3004-1"}],"prev":{"headline":"Unrestricted Upload of File with Dangerous Type in flatcore/flatcore-cms","id":"CVE-2021-3745"},"products":["libtpms"],"published":"2021-10-19","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"A buffer overflow in libtpms allows attackers to cause a denial of service via crafted TPM2 command packets.","url":"https://insights.sbomify.com/CVE-2021-3746/"}