{"answers":{"affected":"2 open source packages ship an affected version, including automad/automad. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-37502 exists.","fix":"Upgrade automad/automad to 1.8.0 or later.","what":"CVE-2021-37502 is a medium-severity cross-site scripting vulnerability in n/a, published on 3 Feb 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-37502 and fix it if it is affected.\n\nWhat it is: CVE-2021-37502 is a medium-severity cross-site scripting vulnerability in n/a, published on 3 Feb 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-37502 exists.\n\nAffected packages and fixed versions:\n- automad/automad (Packagist): affected all versions; fixed in 1.8.0\n- automad/automad (Packagist): affected all versions; fixed in 1.8.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-37502/ (Markdown: https://insights.sbomify.com/CVE-2021-37502/index.md)","id":"CVE-2021-37502","markdown":"https://insights.sbomify.com/CVE-2021-37502/index.md","name":"CVE-2021-37502","record":{"aliases":["GHSA-q3c8-65q7-9v78"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"automad CMS","requires_auth":"low_privilege","summary":"Remote attackers can execute arbitrary code via XSS in the user name field when adding a user in automad.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"automad","vendor":"automad"}],"cvss":{"score":5.4,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross Site Scripting (XSS) vulnerability in automad 1.7.5 allows remote attackers to run arbitrary code via the user name field when adding a user.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Cross site scripting in automad/automad","id":"CVE-2021-37502","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2021"},"n_packages":2,"n_references":1,"next":{"headline":"jQuery-Upload-File XSS in fileNameStr","id":"CVE-2021-37504"},"packages":[{"ecosystem":"Packagist","fixed":["1.8.0"],"introduced":["0"],"last_affected":[],"package":"automad/automad","purl":null,"source":"GHSA-q3c8-65q7-9v78"},{"ecosystem":"Packagist","fixed":["1.8.0"],"introduced":["0"],"last_affected":[],"package":"automad/automad","purl":"pkg:composer/automad/automad","source":"GHSA-q3c8-65q7-9v78"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2021-37501"},"products":["n/a"],"published":"2023-02-03","related":[{"cvss_score":8.8,"headline":"Automad arbitrary file upload vulnerability","id":"CVE-2024-40400","kev_date_added":null,"published":"2024-07-19"},{"cvss_score":6.3,"headline":"automad FileController.php import server-side request forgery","id":"CVE-2023-7037","kev_date_added":null,"published":"2023-12-21"},{"cvss_score":4.8,"headline":"Cross-site scripting in n/a","id":"CVE-2024-40111","kev_date_added":null,"published":"2024-08-23"},{"cvss_score":4.8,"headline":"automad Setting post.php cross site scripting","id":"CVE-2023-7035","kev_date_added":null,"published":"2023-12-21"},{"cvss_score":4.7,"headline":"automad Content Type FileCollectionController.php upload unrestricted upload","id":"CVE-2023-7036","kev_date_added":null,"published":"2023-12-21"},{"cvss_score":4.3,"headline":"automad User Creation cross-site request forgery","id":"CVE-2023-7038","kev_date_added":null,"published":"2023-12-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-26","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary code via XSS in the user name field when adding a user in automad.","url":"https://insights.sbomify.com/CVE-2021-37502/"}