CVE-2021-37517 Access Control vulnerability in Dolibarr
Attackers can cause a Denial of Service in Dolibarr ERP/CRM by exploiting the forgot-password function's handling of email addresses as usernames.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-37517?
CVE-2021-37517 is a high-severity denial of service vulnerability in Dolibarr Dolibarr Erp\/Crm, published on 31 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An Access Control vulnerability exists in Dolibarr ERP/CRM 13.0.2, fixed version is 14.0.0,in the forgot-password function becuase the application allows email addresses as usernames, which can cause a Denial of Service.
Weakness: CWE-863
Which versions are affected by CVE-2021-37517?
3 open source packages ship an affected version, including dolibarr/dolibarr and dolibarr. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
dolibarr/dolibarr Packagist | All versions | 14.0.1 |
dolibarr/dolibarr Packagist | All versions | 14.0.1 |
dolibarr Bitnami | From 13.0.2 to 13.0.2 | None |
Products include Dolibarr Dolibarr Erp\/Crm.
How do I fix CVE-2021-37517?
Upgrade dolibarr/dolibarr to 14.0.1 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2021-37517 being exploited?
There is no known exploitation of CVE-2021-37517 in the wild and no public exploit code.
Other vulnerabilities in Dolibarr Dolibarr Erp\/Crm
Sources
Also known as BIT-dolibarr-2021-37517, GHSA-xw7v-qrhc-jjg2, UBUNTU-CVE-2021-37517.