# CVE-2021-37517: Access Control vulnerability in Dolibarr

> Attackers can cause a Denial of Service in Dolibarr ERP/CRM by exploiting the forgot-password function's handling of email addresses as usernames.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Mar 2022
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-dolibarr-2021-37517, GHSA-xw7v-qrhc-jjg2, UBUNTU-CVE-2021-37517

## What is CVE-2021-37517?

CVE-2021-37517 is a high-severity denial of service vulnerability in Dolibarr Dolibarr Erp\/Crm, published on 31 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An Access Control vulnerability exists in Dolibarr ERP/CRM 13.0.2, fixed version is 14.0.0,in the forgot-password function becuase the application allows email addresses as usernames, which can cause a Denial of Service.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2021-37517?

3 open source packages ship an affected version, including dolibarr/dolibarr and dolibarr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dolibarr/dolibarr` | Packagist | All versions | 14.0.1 |
| `dolibarr/dolibarr` | Packagist | All versions | 14.0.1 |
| `dolibarr` | Bitnami | From 13.0.2 to 13.0.2 | None |

Products: Dolibarr Dolibarr Erp\/Crm.

## How do I fix CVE-2021-37517?

Upgrade dolibarr/dolibarr to 14.0.1 or later.

## Is CVE-2021-37517 being exploited?

There is no known exploitation of CVE-2021-37517 in the wild and no public exploit code.

## Other vulnerabilities in Dolibarr Dolibarr Erp\/Crm

- [CVE-2022-43138](https://insights.sbomify.com/CVE-2022-43138/): Dolibarr vulnerable to privilege escalation (critical 9.8)
- [CVE-2022-40871](https://insights.sbomify.com/CVE-2022-40871/): Dolibarr vulnerable to Eval Injection (critical 9.8)
- [CVE-2021-33816](https://insights.sbomify.com/CVE-2021-33816/): Dolibarr remote PHP code execution (critical 9.8)
- [CVE-2020-7995](https://insights.sbomify.com/CVE-2020-7995/): Dolibarr Improper Restriction of Excessive Authentication Attempts (critical 9.8)
- [CVE-2013-2091](https://insights.sbomify.com/CVE-2013-2091/): SQL injection in dolibarr (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-37517 and fix it if it is affected.

What it is: CVE-2021-37517 is a high-severity denial of service vulnerability in Dolibarr Dolibarr Erp\/Crm, published on 31 Mar 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-37517 in the wild and no public exploit code.

Affected packages and fixed versions:
- dolibarr/dolibarr (Packagist): affected all versions; fixed in 14.0.1
- dolibarr/dolibarr (Packagist): affected all versions; fixed in 14.0.1
- dolibarr (Bitnami): affected from 13.0.2 up to 13.0.2; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-37517/ (Markdown: https://insights.sbomify.com/CVE-2021-37517/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-37517
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-37517
- OSV: https://osv.dev/vulnerability/CVE-2021-37517

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-37517/
Summaries are generated and may contain mistakes; the official description above is the record.
