{"answers":{"affected":"1 open source package ship an affected version, including memcached. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-37519 exists.","fix":"Upgrade memcached to 1.6.10 or later.","what":"CVE-2021-37519 is a medium-severity memory corruption vulnerability in n/a, published on 3 Feb 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-37519 and fix it if it is affected.\n\nWhat it is: CVE-2021-37519 is a medium-severity memory corruption vulnerability in n/a, published on 3 Feb 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-37519 exists.\n\nAffected packages and fixed versions:\n- memcached (Bitnami): affected all versions; fixed in 1.6.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-37519/ (Markdown: https://insights.sbomify.com/CVE-2021-37519/index.md)","id":"CVE-2021-37519","markdown":"https://insights.sbomify.com/CVE-2021-37519/index.md","name":"CVE-2021-37519","record":{"aliases":["BIT-memcached-2021-37519","CLSA-2026-1779095842","DEBIAN-CVE-2021-37519","GHSA-5pff-p34f-mm94","UBUNTU-CVE-2021-37519"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"memcached server","requires_auth":"none","summary":"Attackers can cause a denial of service in memcached by providing a crafted authentication file, requiring specific configuration to exploit.","user_interaction":"required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"memcached","vendor":"memcached"}],"cvss":{"score":5.5,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"}],"description":"Buffer Overflow vulnerability in authfile.c memcached 1.6.9 allows attackers to cause a denial of service via crafted authenticattion file.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Memory corruption in n/a","id":"CVE-2021-37519","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"memory_corruption","year":"2021"},"n_packages":1,"n_references":2,"next":{"headline":"SQL injection in n/a","id":"CVE-2021-37522"},"packages":[{"ecosystem":"Bitnami","fixed":["1.6.10"],"introduced":["0"],"last_affected":[],"package":"memcached","purl":"pkg:bitnami/memcached","source":"BIT-memcached-2021-37519"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2021-37518"},"products":["n/a"],"published":"2023-02-03","related":[{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2023-46853","kev_date_added":null,"published":"2023-10-27"},{"cvss_score":9.8,"headline":"Integer overflow in Memcached","id":"CVE-2016-8704","kev_date_added":null,"published":"2017-01-06"},{"cvss_score":9.8,"headline":"Integer overflow in Memcached","id":"CVE-2016-8705","kev_date_added":null,"published":"2017-01-06"},{"cvss_score":8.1,"headline":"Information disclosure in memcached","id":"CVE-2026-47783","kev_date_added":null,"published":"2026-05-20"},{"cvss_score":8.1,"headline":"Information disclosure in memcached","id":"CVE-2026-47784","kev_date_added":null,"published":"2026-05-20"},{"cvss_score":8.1,"headline":"Integer overflow in Memcached","id":"CVE-2016-8706","kev_date_added":null,"published":"2017-01-06"},{"cvss_score":7.5,"headline":"Memory corruption in n/a","id":"CVE-2023-46852","kev_date_added":null,"published":"2023-10-27"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-26","vendors":["n/a"]},"summary":"Attackers can cause a denial of service in memcached by providing a crafted authentication file, requiring specific configuration to exploit.","url":"https://insights.sbomify.com/CVE-2021-37519/"}