# CVE-2021-37519: Memory corruption in n/a

> Attackers can cause a denial of service in memcached by providing a crafted authentication file, requiring specific configuration to exploit.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Feb 2023
- **Updated:** 26 Mar 2025
- **Also known as:** BIT-memcached-2021-37519, CLSA-2026-1779095842, DEBIAN-CVE-2021-37519, GHSA-5pff-p34f-mm94, UBUNTU-CVE-2021-37519

## What is CVE-2021-37519?

CVE-2021-37519 is a medium-severity memory corruption vulnerability in n/a, published on 3 Feb 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Buffer Overflow vulnerability in authfile.c memcached 1.6.9 allows attackers to cause a denial of service via crafted authenticattion file.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2021-37519?

1 open source package ship an affected version, including memcached. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `memcached` | Bitnami | All versions | 1.6.10 |

Products: Memcached Memcached.

## How do I fix CVE-2021-37519?

Upgrade memcached to 1.6.10 or later.

## Is CVE-2021-37519 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-37519 exists.

## Other vulnerabilities in n/a

- [CVE-2023-46853](https://insights.sbomify.com/CVE-2023-46853/): Memory corruption in n/a (critical 9.8)
- [CVE-2016-8704](https://insights.sbomify.com/CVE-2016-8704/): Integer overflow in Memcached (critical 9.8)
- [CVE-2016-8705](https://insights.sbomify.com/CVE-2016-8705/): Integer overflow in Memcached (critical 9.8)
- [CVE-2026-47783](https://insights.sbomify.com/CVE-2026-47783/): Information disclosure in memcached (high 8.1)
- [CVE-2026-47784](https://insights.sbomify.com/CVE-2026-47784/): Information disclosure in memcached (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-37519 and fix it if it is affected.

What it is: CVE-2021-37519 is a medium-severity memory corruption vulnerability in n/a, published on 3 Feb 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-37519 exists.

Affected packages and fixed versions:
- memcached (Bitnami): affected all versions; fixed in 1.6.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-37519/ (Markdown: https://insights.sbomify.com/CVE-2021-37519/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-37519
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-37519
- OSV: https://osv.dev/vulnerability/CVE-2021-37519

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-37519/
Summaries are generated and may contain mistakes; the official description above is the record.
