# CVE-2021-37580: Apache ShenYu Admin bypass JWT authentication

> An attacker can bypass authentication in Apache ShenYu Admin due to incorrect JWT usage, gaining unauthorized access to the system.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Nov 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-vpfp-5gwq-g533

## What is CVE-2021-37580?

CVE-2021-37580 is a critical authentication bypass vulnerability in Apache ShenYu Admin, published on 16 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A flaw was found in Apache ShenYu Admin. The incorrect use of JWT in ShenyuAdminBootstrap allows an attacker to bypass authentication. This issue affected Apache ShenYu 2.3.0 and 2.4.0

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2021-37580?

2 open source packages ship an affected version, including org.apache.shenyu:shenyu-admin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.shenyu:shenyu-admin` | Maven | From 2.3.0 | 2.4.1 |
| `org.apache.shenyu:shenyu-admin` | Maven | From 2.3.0 | 2.4.1 |

Products: Apache Shenyu.

## How do I fix CVE-2021-37580?

Upgrade org.apache.shenyu:shenyu-admin to 2.4.1 or later.

## Is CVE-2021-37580 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-37580 exists.

Public exploit code:

- CVE-2021-37580的poc (github_poc): https://github.com/fengwenhua/CVE-2021-37580
- CVE-2021-37580 (github_poc): https://github.com/Liang2580/CVE-2021-37580
- https://github.com/ZororoZ/CVE-2021-37580 (github_poc): https://github.com/ZororoZ/CVE-2021-37580
- https://github.com/rabbitsafe/CVE-2021-37580 (github_poc): https://github.com/rabbitsafe/CVE-2021-37580
- Apache ShenYu Admin JWT认证绕过漏洞(CVE-2021-37580) (github_poc): https://github.com/CN016/Apache-ShenYu-Admin-JWT-CVE-2021-37580-
- A vulnerability scanner that detects CVE-2021-37580 vulnerabilities. (github_poc): https://github.com/Osyanina/westone-CVE-2021-37580-scanner

## Other vulnerabilities in Apache ShenYu Admin

- [CVE-2021-45029](https://insights.sbomify.com/CVE-2021-45029/): Apache ShenYu 2.4.1 Groovy Code Injection & SpEL Injection (critical 9.8)
- [CVE-2022-23944](https://insights.sbomify.com/CVE-2022-23944/): Apache ShenYu 2.4.1 Improper access control (critical 9.1)
- [CVE-2022-42735](https://insights.sbomify.com/CVE-2022-42735/): Apache ShenYu Admin ultra vires (high 8.8)
- [CVE-2022-37435](https://insights.sbomify.com/CVE-2022-37435/): Apache ShenYu Admin Improper Privilege Management (high 8.8)
- [CVE-2022-26650](https://insights.sbomify.com/CVE-2022-26650/): Apache ShenYu (incubating) Regular expression denial of service (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-37580 and fix it if it is affected.

What it is: CVE-2021-37580 is a critical authentication bypass vulnerability in Apache ShenYu Admin, published on 16 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-37580 exists.

Affected packages and fixed versions:
- org.apache.shenyu:shenyu-admin (Maven): affected from 2.3.0; fixed in 2.4.1
- org.apache.shenyu:shenyu-admin (Maven): affected from 2.3.0; fixed in 2.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-37580/ (Markdown: https://insights.sbomify.com/CVE-2021-37580/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-37580
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-37580
- OSV: https://osv.dev/vulnerability/CVE-2021-37580

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-37580/
Summaries are generated and may contain mistakes; the official description above is the record.
