# CVE-2021-3761: OctoRPKI lacks contextual out-of-bounds check when validating RPKI ROA maxLength values

> Attackers can crash RTR sessions by sending invalid RPKI data, disabling origin validation and enabling BGP hijacks.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Sep 2021
- **Updated:** 17 Sep 2024
- **Also known as:** DEBIAN-CVE-2021-3761, GHSA-c8xp-8mf3-62h9, GO-2022-0246

## What is CVE-2021-3761?

CVE-2021-3761 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 9 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Any CA issuer in the RPKI can trick OctoRPKI prior to 1.3.0 into emitting an invalid VRP "MaxLength" value, causing RTR sessions to terminate. An attacker can use this to disable RPKI Origin Validation in a victim network (for example AS 13335 - Cloudflare) prior to launching a BGP hijack which during normal operations would be rejected as "RPKI invalid". Additionally, in certain deployments RTR session flapping in and of itself also could cause BGP routing churn, causing availability issues.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2021-3761?

3 open source packages ship an affected version, including github.com/cloudflare/cfrpki. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/cloudflare/cfrpki` | Go | All versions | 1.3.0 |
| `github.com/cloudflare/cfrpki` | Go | All versions | 1.3.0 |
| `github.com/cloudflare/cfrpki` | Go | All versions | 1.3.0 |

Products: Cloudflare Octorpki, Debian Debian Linux.

## How do I fix CVE-2021-3761?

Upgrade github.com/cloudflare/cfrpki to 1.3.0 or later.

## Is CVE-2021-3761 being exploited?

There is no known exploitation of CVE-2021-3761 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2021-3978](https://insights.sbomify.com/CVE-2021-3978/): Improper Preservation of Permissions in github.com/cloudflare/cfrpki/cmd/octorpki (high 7.5)
- [CVE-2021-3907](https://insights.sbomify.com/CVE-2021-3907/): Arbitrary filepath traversal via URI injection (high 7.4)
- [CVE-2021-3908](https://insights.sbomify.com/CVE-2021-3908/): Infinite certificate chain depth results in OctoRPKI running forever (medium 5.9)
- [CVE-2022-3616](https://insights.sbomify.com/CVE-2022-3616/): OctoRPKI crash when maximum iterations number is reached (medium 5.4)
- [CVE-2021-3909](https://insights.sbomify.com/CVE-2021-3909/): Infinite open connection causes OctoRPKI to hang forever (medium 4.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-3761 and fix it if it is affected.

What it is: CVE-2021-3761 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 9 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-3761 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/cloudflare/cfrpki (Go): affected all versions; fixed in 1.3.0
- github.com/cloudflare/cfrpki (Go): affected all versions; fixed in 1.3.0
- github.com/cloudflare/cfrpki (Go): affected all versions; fixed in 1.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-3761/ (Markdown: https://insights.sbomify.com/CVE-2021-3761/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-3761
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-3761
- OSV: https://osv.dev/vulnerability/CVE-2021-3761

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-3761/
Summaries are generated and may contain mistakes; the official description above is the record.
