# CVE-2021-37616: Null pointer dereference in Exiv2::Internal::resolveLens0x8ff

> Attackers can cause denial of service via crafted image files when Exiv2 prints interpreted metadata using specific command-line options.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Aug 2021
- **Updated:** 4 Aug 2024
- **Also known as:** AZL-7219, CLEANSTART-2024-FF55926, DEBIAN-CVE-2021-37616, GHSA-54f7-vvj7-545w, JLSEC-2026-1307, UBUNTU-CVE-2021-37616

## What is CVE-2021-37616?

CVE-2021-37616 is a medium-severity vulnerability in Exiv2 Exiv2, published on 9 Aug 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. A null pointer dereference was found in Exiv2 versions v0.27.4 and earlier. The null pointer dereference is triggered when Exiv2 is used to print the metadata of a crafted image file. An attacker could potentially exploit the vulnerability to cause a denial of service, if they can trick the victim into running Exiv2 on a crafted image file. Note that this bug is only triggered when printing the interpreted (translated) data, which is a less frequently used Exiv2 operation that requires an extra command line option (`-p t` or `-P t`). The bug is fixed in version v0.27.5.

Weakness: CWE-476 (NULL Pointer Dereference)

## Which versions are affected by CVE-2021-37616?

It affects 2 products.


Products: Exiv2 Exiv2, Fedoraproject Fedora.

## How do I fix CVE-2021-37616?

Upgrade to a fixed version.

## Is CVE-2021-37616 being exploited?

There is no known exploitation of CVE-2021-37616 in the wild and no public exploit code.

## Other vulnerabilities in Exiv2 Exiv2

- [CVE-2023-44398](https://insights.sbomify.com/CVE-2023-44398/): Out-of-bounds write in exiv2 (high 8.8)
- [CVE-2019-9143](https://insights.sbomify.com/CVE-2019-9143/): Denial of service in n/a (high 8.8)
- [CVE-2019-9144](https://insights.sbomify.com/CVE-2019-9144/): Denial of service in n/a (high 8.8)
- [CVE-2018-14046](https://insights.sbomify.com/CVE-2018-14046/): Memory corruption in n/a (high 8.8)
- [CVE-2017-12955](https://insights.sbomify.com/CVE-2017-12955/): Memory corruption in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-37616 and fix it if it is affected.

What it is: CVE-2021-37616 is a medium-severity vulnerability in Exiv2 Exiv2, published on 9 Aug 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-37616 in the wild and no public exploit code.

Affected product: Exiv2 Exiv2. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-37616/ (Markdown: https://insights.sbomify.com/CVE-2021-37616/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-37616
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-37616
- OSV: https://osv.dev/vulnerability/CVE-2021-37616

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-37616/
Summaries are generated and may contain mistakes; the official description above is the record.
