# CVE-2021-37624: FreeSWITCH does not authenticate SIP MESSAGE requests, leading to spam and message spoofing

> Attackers can send unauthenticated SIP messages to registered users, enabling spam and spoofing, unless authentication is explicitly enabled.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Oct 2021
- **Updated:** 4 Aug 2024
- **Also known as:** ALPINE-CVE-2021-37624, GHSA-mjcm-q9h8-9xv3

## What is CVE-2021-37624?

CVE-2021-37624 is a high-severity missing authorization vulnerability in signalwire freeswitch, published on 25 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

FreeSWITCH is a Software Defined Telecom Stack enabling the digital transformation from proprietary telecom switches to a software implementation that runs on any commodity hardware. Prior to version 1.10.7, FreeSWITCH does not authenticate SIP MESSAGE requests, leading to spam and message spoofing. By default, SIP requests of the type MESSAGE (RFC 3428) are not authenticated in the affected versions of FreeSWITCH. MESSAGE requests are relayed to SIP user agents registered with the FreeSWITCH server without requiring any authentication. Although this behaviour can be changed by setting the `auth-messages` parameter to `true`, it is not the default setting. Abuse of this security issue allows attackers to send SIP MESSAGE messages to any SIP user agent that is registered with the server without requiring authentication. Additionally, since no authentication is required, chat messages can be spoofed to appear to come from trusted entities. Therefore, abuse can lead to spam and enable social engineering, phishing and similar attacks. This issue is patched in version 1.10.7. Maintainers recommend that this SIP message type is authenticated by default so that FreeSWITCH administrators do not need to be explicitly set the `auth-messages` parameter. When following such a recommendation, a new parameter can be introduced to explicitly disable authentication.

Weakness: CWE-306 (Missing Authentication for Critical Functionality), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2021-37624?

It affects 1 product.


Products: Freeswitch Freeswitch.

## How do I fix CVE-2021-37624?

Upgrade to a fixed version.

## Is CVE-2021-37624 being exploited?

There is no known exploitation of CVE-2021-37624 in the wild and no public exploit code.

Public exploit code:

- A FreeSWITCH specific scanning and exploitation toolkit for CVE-2021-37624 and CVE-2021-41157. (github_poc): https://github.com/0xInfection/PewSWITCH

## Other vulnerabilities in signalwire freeswitch

- [CVE-2026-49841](https://insights.sbomify.com/CVE-2026-49841/): FreeSWITCH: Pre-authentication heap buffer overflow in `mod_verto` HTTP POST body read (critical 9.8)
- [CVE-2019-19492](https://insights.sbomify.com/CVE-2019-19492/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2026-49840](https://insights.sbomify.com/CVE-2026-49840/): FreeSWITCH: Pre-authentication heap buffer overflow in libesl `Content-Length` parsing (critical 9.1)
- [CVE-2021-41145](https://insights.sbomify.com/CVE-2021-41145/): FreeSWITCH susceptible to Denial of Service via SIP flooding (high 8.6)
- [CVE-2026-45771](https://insights.sbomify.com/CVE-2026-45771/): Freeswitch Denial-of-Service in SIP PUBLISH Requests via XML Entity Expansion (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-37624 and fix it if it is affected.

What it is: CVE-2021-37624 is a high-severity missing authorization vulnerability in signalwire freeswitch, published on 25 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-37624 in the wild and no public exploit code.

Affected product: signalwire freeswitch. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-37624/ (Markdown: https://insights.sbomify.com/CVE-2021-37624/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-37624
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-37624
- OSV: https://osv.dev/vulnerability/CVE-2021-37624

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-37624/
Summaries are generated and may contain mistakes; the official description above is the record.
