CVE-2021-37632 Deserialization of Untrusted Data in com.supermartijn642.configlib.ConfigSyncPacket
An attacker can achieve remote code execution by sending malicious packets to Minecraft servers or clients using the vulnerable Config Lib library.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2021-37632?
CVE-2021-37632 is a high-severity unsafe deserialization vulnerability in SuperMartijn642sConfigLib, published on 5 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
SuperMartijn642's Config Lib is a library used by a number of mods for the game Minecraft. The versions of SuperMartijn642's Config Lib between 1.0.4 and 1.0.8 are affected by a vulnerability and can be exploited on both servers and clients. Using SuperMartijn642's Config Lib, servers will send a packet to clients with the server's config values. In order to read `enum` values from the packet data, `ObjectInputStream#readObject` is used. `ObjectInputStream#readObject` will instantiate a class based on the input data. Since, the packet data is not validated before `ObjectInputStream#readObject` is called, an attacker can instantiate any class by sending a malicious packet. If a suitable class is found, the vulnerability can lead to a number of exploits, including remote code execution. Although the vulnerable packet is typically only send from server to client, it can theoretically also be send from client to server. This means both clients and servers running SuperMartijn642's Config Lib between 1.0.4 and 1.0.8 are vulnerable. The vulnerability has been patched in SuperMartijn642's Config lib 1.0.9. Both, players and server owners, should update to 1.0.9 or higher.
Weakness: CWE-502
Which versions are affected by CVE-2021-37632?
It affects 1 product.
Products include Config Lib Project Config Lib.
How do I fix CVE-2021-37632?
No fix has been published for CVE-2021-37632 yet. Limit exposure of the affected software until one is available.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2021-37632 being exploited?
There is no known exploitation of CVE-2021-37632 in the wild and no public exploit code.