{"answers":{"affected":"2 open source packages ship an affected version, including validator. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-3765 in the wild and no public exploit code.","fix":"Upgrade validator to 13.7.0 or later.","what":"CVE-2021-3765 is a medium-severity denial of service vulnerability in validatorjs/validator.js, published on 2 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-3765 and fix it if it is affected.\n\nWhat it is: CVE-2021-3765 is a medium-severity denial of service vulnerability in validatorjs/validator.js, published on 2 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-3765 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- validator (npm): affected all versions; fixed in 13.7.0\n- validator (npm): affected all versions; fixed in 13.7.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-3765/ (Markdown: https://insights.sbomify.com/CVE-2021-3765/index.md)","id":"CVE-2021-3765","markdown":"https://insights.sbomify.com/CVE-2021-3765/index.md","name":"CVE-2021-3765","record":{"aliases":["CLSA-2026-1789162879","CLSA-2026-1790176084","GHSA-qgmg-gppg-76g5","MINI-2hvm-56g4-8j2f","MINI-5x6c-9jrc-rg6w","ROOT-APP-NPM-CVE-2021-3765","UBUNTU-CVE-2021-3765"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript validation library","requires_auth":"none","summary":"An attacker can cause a denial of service by submitting specially crafted input that triggers inefficient regular expression processing in the validator.js library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"validator","vendor":"validator_project"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.0"},"cwes":[{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"validator.js is vulnerable to Inefficient Regular Expression Complexity","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Inefficient Regular Expression Complexity in validatorjs/validator.js","id":"CVE-2021-3765","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2021"},"n_packages":2,"n_references":2,"next":{"headline":"Prototype Pollution in vincit/objection.js","id":"CVE-2021-3766"},"packages":[{"ecosystem":"npm","fixed":["13.7.0"],"introduced":["0"],"last_affected":[],"package":"validator","purl":null,"source":"GHSA-qgmg-gppg-76g5"},{"ecosystem":"npm","fixed":["13.7.0"],"introduced":["0"],"last_affected":[],"package":"validator","purl":"pkg:npm/validator","source":"GHSA-qgmg-gppg-76g5"}],"prev":{"headline":"Denial of service in Linux Kernel","id":"CVE-2021-3764"},"products":["validatorjs/validator.js"],"published":"2021-11-02","related":[{"cvss_score":8.7,"headline":"Validator is Vulnerable to Incomplete Filtering of One or More Instances of Special Elements","id":"CVE-2025-12758","kev_date_added":null,"published":"2025-11-27"},{"cvss_score":6.1,"headline":"validator.js has a URL validation bypass vulnerability in its isURL function","id":"CVE-2025-56200","kev_date_added":null,"published":"2025-09-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["validatorjs"]},"summary":"An attacker can cause a denial of service by submitting specially crafted input that triggers inefficient regular expression processing in the validator.js library.","url":"https://insights.sbomify.com/CVE-2021-3765/"}