# CVE-2021-3765: Inefficient Regular Expression Complexity in validatorjs/validator.js

> An attacker can cause a denial of service by submitting specially crafted input that triggers inefficient regular expression processing in the validator.js library.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Nov 2021
- **Updated:** 3 Aug 2024
- **Also known as:** CLSA-2026-1789162879, CLSA-2026-1790176084, GHSA-qgmg-gppg-76g5, MINI-2hvm-56g4-8j2f, MINI-5x6c-9jrc-rg6w, ROOT-APP-NPM-CVE-2021-3765, UBUNTU-CVE-2021-3765

## What is CVE-2021-3765?

CVE-2021-3765 is a medium-severity denial of service vulnerability in validatorjs/validator.js, published on 2 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

validator.js is vulnerable to Inefficient Regular Expression Complexity

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2021-3765?

2 open source packages ship an affected version, including validator. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `validator` | npm | All versions | 13.7.0 |
| `validator` | npm | All versions | 13.7.0 |

Products: Validator Project Validator.

## How do I fix CVE-2021-3765?

Upgrade validator to 13.7.0 or later.

## Is CVE-2021-3765 being exploited?

There is no known exploitation of CVE-2021-3765 in the wild and no public exploit code.

## Other vulnerabilities in validatorjs/validator.js

- [CVE-2025-12758](https://insights.sbomify.com/CVE-2025-12758/): Validator is Vulnerable to Incomplete Filtering of One or More Instances of Special Elements (high 8.7)
- [CVE-2025-56200](https://insights.sbomify.com/CVE-2025-56200/): validator.js has a URL validation bypass vulnerability in its isURL function (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-3765 and fix it if it is affected.

What it is: CVE-2021-3765 is a medium-severity denial of service vulnerability in validatorjs/validator.js, published on 2 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-3765 in the wild and no public exploit code.

Affected packages and fixed versions:
- validator (npm): affected all versions; fixed in 13.7.0
- validator (npm): affected all versions; fixed in 13.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-3765/ (Markdown: https://insights.sbomify.com/CVE-2021-3765/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-3765
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-3765
- OSV: https://osv.dev/vulnerability/CVE-2021-3765

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-3765/
Summaries are generated and may contain mistakes; the official description above is the record.
