# CVE-2021-37694: Code injection issue for java-spring-cloud-stream-template

> Attackers can inject arbitrary code into generated Spring Cloud Stream microservices by controlling the AsyncAPI document.

- **Severity:** High 8.7 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Aug 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-xj6r-2jpm-qvxp

## What is CVE-2021-37694?

CVE-2021-37694 is a high-severity code injection vulnerability in asyncapi java-spring-cloud-stream-template, published on 11 Aug 2021. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

@asyncapi/java-spring-cloud-stream-template generates a Spring Cloud Stream (SCSt) microservice. In versions prior to 0.7.0 arbitrary code injection was possible when an attacker controls the AsyncAPI document. An example is provided in GHSA-xj6r-2jpm-qvxp. There are no mitigations available and all users are advised to update.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2021-37694?

2 open source packages ship an affected version, including @asyncapi/java-spring-cloud-stream-template. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@asyncapi/java-spring-cloud-stream-template` | npm | All versions | 0.7.0 |
| `@asyncapi/java-spring-cloud-stream-template` | npm | All versions | 0.7.0 |

Products: Asyncapi Java-Spring-Cloud-Stream-Template.

## How do I fix CVE-2021-37694?

Upgrade @asyncapi/java-spring-cloud-stream-template to 0.7.0 or later.

## Is CVE-2021-37694 being exploited?

There is no known exploitation of CVE-2021-37694 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-37694 and fix it if it is affected.

What it is: CVE-2021-37694 is a high-severity code injection vulnerability in asyncapi java-spring-cloud-stream-template, published on 11 Aug 2021. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-37694 in the wild and no public exploit code.

Affected packages and fixed versions:
- @asyncapi/java-spring-cloud-stream-template (npm): affected all versions; fixed in 0.7.0
- @asyncapi/java-spring-cloud-stream-template (npm): affected all versions; fixed in 0.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-37694/ (Markdown: https://insights.sbomify.com/CVE-2021-37694/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-37694
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-37694
- OSV: https://osv.dev/vulnerability/CVE-2021-37694

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-37694/
Summaries are generated and may contain mistakes; the official description above is the record.
