CVE-2021-37699 Open Redirect in Next.js versions below 11.1.0

Medium 6.9 Published Updated

Attackers can redirect users to malicious sites via specially encoded paths in statically generated error pages, facilitating phishing attacks.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2021-37699?

CVE-2021-37699 is a medium-severity vulnerability in Vercel Next.js, published on 11 Aug 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Next.js is an open source website development framework to be used with the React library. In affected versions specially encoded paths could be used when pages/_error.js was statically generated allowing an open redirect to occur to an external site. In general, this redirect does not directly harm users although can allow for phishing attacks by redirecting to an attacker's domain from a trusted domain. We recommend everyone to upgrade regardless of whether you can reproduce the issue or not. The issue has been patched in release 11.1.0.

Weakness: CWE-601

Which versions are affected by CVE-2021-37699?

2 open source packages ship an affected version, including next. It affects 1 product.

PackageAffectedFixed in
next npmFrom 0.9.911.1.0
next npmFrom 0.9.911.1.0

Products include Vercel Next.js.

How do I fix CVE-2021-37699?

Upgrade next to 11.1.0 or later.

Is CVE-2021-37699 being exploited?

There is no known exploitation of CVE-2021-37699 in the wild and no public exploit code.

All Vercel Next.js vulnerabilities

Sources

Also known as GHSA-vxf5-wxwp-m7g9.

Is CVE-2021-37699 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free