{"answers":{"affected":"6 open source packages ship an affected version, including phpfastcache/phpfastcache. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-37704 exists.","fix":"Upgrade phpfastcache/phpfastcache to a fixed version for your release line: 6.1.5, 7.1.2 or 8.0.7.","what":"CVE-2021-37704 is a medium-severity vulnerability in PHPSocialNetwork phpfastcache, published on 12 Aug 2021. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-37704 and fix it if it is affected.\n\nWhat it is: CVE-2021-37704 is a medium-severity vulnerability in PHPSocialNetwork phpfastcache, published on 12 Aug 2021. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-37704 exists.\n\nAffected packages and fixed versions:\n- phpfastcache/phpfastcache (Packagist): affected all versions; fixed in 6.1.5\n- phpfastcache/phpfastcache (Packagist): affected all versions; fixed in 6.1.5\n- phpfastcache/phpfastcache (Packagist): affected from 7.0.0; fixed in 7.1.2\n- phpfastcache/phpfastcache (Packagist): affected from 7.0.0; fixed in 7.1.2\n- phpfastcache/phpfastcache (Packagist): affected from 8.0.0; fixed in 8.0.7\n- phpfastcache/phpfastcache (Packagist): affected from 8.0.0; fixed in 8.0.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-37704/ (Markdown: https://insights.sbomify.com/CVE-2021-37704/index.md)","id":"CVE-2021-37704","markdown":"https://insights.sbomify.com/CVE-2021-37704/index.md","name":"CVE-2021-37704","record":{"aliases":["GHSA-cvh5-p6r6-g2qc"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"PHP caching library","requires_auth":"low_privilege","summary":"An attacker can access sensitive system configuration details via exposed phpinfo() if the vendor directory is publicly accessible.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"phpfastcache","vendor":"phpfastcache"}],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-668","name":"Exposure of Resource to Wrong Sphere"},{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"PhpFastCache is a high-performance backend cache system (packagist package phpfastcache/phpfastcache). In versions before 6.1.5, 7.1.2, and 8.0.7 the `phpinfo()` can be exposed if the `/vendor` is not protected from public access. This is a rare situation today since the vendor directory is often located outside the web directory or protected via server rule (.htaccess, etc). Only the v6, v7 and v8 will be patched respectively in 8.0.7, 7.1.2, 6.1.5. Older versions such as v5, v4 are not longer supported and will **NOT** be patched. As a workaround, protect the `/vendor` directory from public access.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":1,"refs":[{"date":null,"kind":"nuclei","ref":"http/cves/2021/CVE-2021-37704.yaml","stars":null,"title":"phpfastcache - phpinfo Resource Exposure"}],"tier":"weaponised"},"has_fix":true,"headline":"Exposed phpinfo() in PhpFastCache","id":"CVE-2021-37704","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"information_disclosure","year":"2021"},"n_packages":6,"n_references":8,"next":{"headline":"Improper Authorization and Origin Validation Error in OneFuzz","id":"CVE-2021-37705"},"packages":[{"ecosystem":"Packagist","fixed":["6.1.5"],"introduced":["0"],"last_affected":[],"package":"phpfastcache/phpfastcache","purl":null,"source":"GHSA-cvh5-p6r6-g2qc"},{"ecosystem":"Packagist","fixed":["6.1.5"],"introduced":["0"],"last_affected":[],"package":"phpfastcache/phpfastcache","purl":"pkg:composer/phpfastcache/phpfastcache","source":"GHSA-cvh5-p6r6-g2qc"},{"ecosystem":"Packagist","fixed":["7.1.2"],"introduced":["7.0.0"],"last_affected":[],"package":"phpfastcache/phpfastcache","purl":null,"source":"GHSA-cvh5-p6r6-g2qc"},{"ecosystem":"Packagist","fixed":["7.1.2"],"introduced":["7.0.0"],"last_affected":[],"package":"phpfastcache/phpfastcache","purl":"pkg:composer/phpfastcache/phpfastcache","source":"GHSA-cvh5-p6r6-g2qc"},{"ecosystem":"Packagist","fixed":["8.0.7"],"introduced":["8.0.0"],"last_affected":[],"package":"phpfastcache/phpfastcache","purl":null,"source":"GHSA-cvh5-p6r6-g2qc"},{"ecosystem":"Packagist","fixed":["8.0.7"],"introduced":["8.0.0"],"last_affected":[],"package":"phpfastcache/phpfastcache","purl":"pkg:composer/phpfastcache/phpfastcache","source":"GHSA-cvh5-p6r6-g2qc"}],"prev":{"headline":"Information exposure in Discourse","id":"CVE-2021-37703"},"products":["phpfastcache"],"published":"2021-08-12","related":[{"cvss_score":4.4,"headline":"Object injection in cookie driver","id":"CVE-2019-16774","kev_date_added":null,"published":"2019-12-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["PHPSocialNetwork"]},"summary":"An attacker can access sensitive system configuration details via exposed phpinfo() if the vendor directory is publicly accessible.","url":"https://insights.sbomify.com/CVE-2021-37704/"}