CVE-2021-37708 Command injection in mail agent settings
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2021-37708?
CVE-2021-37708 is a high-severity vulnerability in Shopware Shopware, published on 16 Aug 2021.
Official description
Shopware is an open source eCommerce platform. Versions prior to 6.4.3.1 contain a command injection vulnerability in mail agent settings. Version 6.4.3.1 contains a patch. As workarounds for older versions of 6.1, 6.2, and 6.3, corresponding security measures are also available via a plugin.
Which versions are affected by CVE-2021-37708?
4 open source packages ship an affected version, including shopware/core and shopware/platform. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
shopware/core Packagist | All versions | 6.4.3.1 |
shopware/core Packagist | All versions | 6.4.3.1 |
shopware/platform Packagist | All versions | 6.4.3.1 |
shopware/platform Packagist | All versions | 6.4.3.1 |
Products include Shopware Shopware.
How do I fix CVE-2021-37708?
Upgrade shopware/core to 6.4.3.1 or later.
Is CVE-2021-37708 being exploited?
There is no known exploitation of CVE-2021-37708 in the wild and no public exploit code.
Other vulnerabilities in Shopware Shopware
- CVE-2023-22731 Improper Control of Generation of Code in Twig rendered views in shopware
- CVE-2016-3109 Shopware RCE Vulnerability
- CVE-2024-22406 Blind SQL-injection in DAL aggregations in Shopware
- CVE-2021-32711 Leak of information via Store-API
- CVE-2026-31887 Shopware unauthenticated data extraction possible through store-api.order endpoint
Sources
Also known as GHSA-xh55-2fqp-p775.