CVE-2021-37710 Cross-Site Scripting via SVG media files

High 8.0 Published Updated

Attackers can execute arbitrary scripts in user browsers by uploading malicious SVG files, potentially leading to session hijacking or data theft.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2021-37710?

CVE-2021-37710 is a high-severity cross-site scripting vulnerability in Shopware Shopware, published on 16 Aug 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Shopware is an open source eCommerce platform. Versions prior to 6.4.3.1 contain a Cross-Site Scripting vulnerability via SVG media files. Version 6.4.3.1 contains a patch. As workarounds for older versions of 6.1, 6.2, and 6.3, corresponding security measures are also available via a plugin.

Weakness: CWE-79

Which versions are affected by CVE-2021-37710?

4 open source packages ship an affected version, including shopware/core and shopware/platform. It affects 1 product.

PackageAffectedFixed in
shopware/core PackagistAll versions6.4.3.1
shopware/core PackagistAll versions6.4.3.1
shopware/platform PackagistAll versions6.4.3.1
shopware/platform PackagistAll versions6.4.3.1

Products include Shopware Shopware.

How do I fix CVE-2021-37710?

Upgrade shopware/core to 6.4.3.1 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2021-37710 being exploited?

There is no known exploitation of CVE-2021-37710 in the wild and no public exploit code.

All Shopware Shopware vulnerabilities

Sources

Also known as GHSA-fc38-mxwr-pfhx.

Is CVE-2021-37710 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free