# CVE-2021-37713: Arbitrary File Creation/Overwrite on Windows via insufficient relative path sanitization

> Arbitrary file creation and code execution via path traversal on Windows in node-tar due to insufficient sanitization of drive-letter paths.

- **Severity:** High 8.2 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 Aug 2021
- **Updated:** 4 Aug 2024
- **Also known as:** ALPINE-CVE-2021-37713, CLEANSTART-2026-BE95243, CLEANSTART-2026-BX59752, GHSA-5955-9wpr-37jh, ROOT-APP-NPM-CVE-2021-37713

## What is CVE-2021-37713?

CVE-2021-37713 is a high-severity path traversal vulnerability in Oracle Graalvm, published on 31 Aug 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

The npm package "tar" (aka node-tar) before versions 4.4.18, 5.0.10, and 6.1.9 has an arbitrary file creation/overwrite and arbitrary code execution vulnerability. node-tar aims to guarantee that any file whose location would be outside of the extraction target directory is not extracted. This is, in part, accomplished by sanitizing absolute paths of entries within the archive, skipping archive entries that contain `..` path portions, and resolving the sanitized paths against the extraction target directory. This logic was insufficient on Windows systems when extracting tar files that contained a path that was not an absolute path, but specified a drive letter different from the extraction target, such as `C:some\path`. If the drive letter does not match the extraction target, for example `D:\extraction\dir`, then the result of `path.resolve(extractionDirectory, entryPath)` would resolve against the current working directory on the `C:` drive, rather than the extraction target directory. Additionally, a `..` portion of the path could occur immediately after the drive letter, such as `C:../foo`, and was not properly sanitized by the logic that checked for `..` within the normalized and split portions of the path. This only affects users of `node-tar` on Windows systems. These issues were addressed in releases 4.4.18, 5.0.10 and 6.1.9. The v3 branch of node-tar has been deprecated and did not receive patches for these issues. If you are still using a v3 release we recommend you update to a more recent version of node-tar. There is no reasonable way to work around this issue without performing the same path normalization procedures that node-tar now does. Users are encouraged to upgrade to the latest patched versions of node-tar, rather than attempt to sanitize paths themselves.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2021-37713?

6 open source packages ship an affected version, including tar. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tar` | npm | All versions | 4.4.18 |
| `tar` | npm | All versions | 4.4.18 |
| `tar` | npm | From 5.0.0 | 5.0.10 |
| `tar` | npm | From 5.0.0 | 5.0.10 |
| `tar` | npm | From 6.0.0 | 6.1.9 |
| `tar` | npm | From 6.0.0 | 6.1.9 |

Products: Npmjs Tar, Oracle Graalvm, Siemens Sinec Infrastructure Network Services.

## How do I fix CVE-2021-37713?

Upgrade tar to a fixed version for your release line: 4.4.18, 5.0.10 or 6.1.9.

## Is CVE-2021-37713 being exploited?

There is no known exploitation of CVE-2021-37713 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-37713 and fix it if it is affected.

What it is: CVE-2021-37713 is a high-severity path traversal vulnerability in Oracle Graalvm, published on 31 Aug 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-37713 in the wild and no public exploit code.

Affected packages and fixed versions:
- tar (npm): affected all versions; fixed in 4.4.18
- tar (npm): affected all versions; fixed in 4.4.18
- tar (npm): affected from 5.0.0; fixed in 5.0.10
- tar (npm): affected from 5.0.0; fixed in 5.0.10
- tar (npm): affected from 6.0.0; fixed in 6.1.9
- tar (npm): affected from 6.0.0; fixed in 6.1.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-37713/ (Markdown: https://insights.sbomify.com/CVE-2021-37713/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-37713
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-37713
- OSV: https://osv.dev/vulnerability/CVE-2021-37713

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-37713/
Summaries are generated and may contain mistakes; the official description above is the record.
